summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbd83c658885
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by makepkg 4.2.1
+# Sun May 17 04:29:56 UTC 2015
+pkgbase = stm8flash-git
+ pkgdesc = Utility for flashing STM8 MCU family via ST-LINK (V1 and V2)
+ pkgver = 20150517
+ pkgrel = 1
+ url = https://github.com/vdudouyt/stm8flash
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = libusb
+
+pkgname = stm8flash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd6cb6296b51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname="stm8flash-git"
+pkgver="20150517"
+pkgrel="1"
+pkgdesc="Utility for flashing STM8 MCU family via ST-LINK (V1 and V2)"
+arch=('i686' 'x86_64')
+url='https://github.com/vdudouyt/stm8flash'
+license=('GPL2')
+depends=('libusb')
+makedepends=('git')
+source=()
+md5sums=()
+
+build() {
+ cd "${srcdir}"
+ git clone https://github.com/vdudouyt/stm8flash
+ cd "stm8flash"
+ make
+}
+
+package() {
+ cd "${srcdir}/stm8flash"
+ mkdir -p "${pkgdir}/usr/bin"
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file