summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD82
-rw-r--r--initcpio-install46
-rw-r--r--org.storage.stratis1.service5
-rw-r--r--stratisd-boot.service17
-rw-r--r--stratisd.service17
6 files changed, 16 insertions, 166 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc6cdcbe37da..b23105fe53be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = stratisd
- pkgdesc = Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.
+ pkgdesc = Easy to use local storage management for Linux.
pkgver = 0.5.5
pkgrel = 1
url = https://stratis-storage.github.io/
@@ -7,21 +7,10 @@ pkgbase = stratisd
license = MPL2
makedepends = asciidoc
makedepends = cargo
- makedepends = git
- makedepends = mpfr
makedepends = rust
- provides = stratisd
- conflicts = stratisd
+ makedepends = git
source = stratisd-0.5.5.tar.gz::https://github.com/stratis-storage/stratisd/archive/v0.5.5.tar.gz
- source = initcpio-install
- source = org.storage.stratis1.service
- source = stratisd.service
- source = stratisd-boot.service
sha256sums = ca0de355c1ae5caa562b3fae5554eb8bae8f1916b3ef7052ec5d88037eaf0458
- sha256sums = e12069c231c3f7c6e16b347ffcddb5cf919c9e5105c56a7b9a994e1adc49da25
- sha256sums = 72ab992ff564d4dd6f0290bd12e973268e45ac0b154e4695796e9737ffed31fe
- sha256sums = 2143a3f942a3c2975a006c96ec78cf960417943a2425b564f91425f3a50a7ccd
- sha256sums = cf2a2ed28cdcfa2a3b90b63a50a6ab8ca9690f8def273feab2d92d84113b931c
pkgname = stratisd
diff --git a/PKGBUILD b/PKGBUILD
index 5e452299eaf6..e912128e753f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,58 +3,26 @@
pkgname='stratisd'
pkgver=0.5.5
pkgrel=1
-pkgdesc='Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.'
+pkgdesc='Easy to use local storage management for Linux.'
arch=('x86_64')
url='https://stratis-storage.github.io/'
license=('MPL2')
-makedepends=('asciidoc' 'cargo' 'git' 'mpfr' 'rust')
-provides=("${pkgname}")
-conflicts=("${pkgname}")
-source=(
- "${pkgname}-${pkgver}.tar.gz::https://github.com/stratis-storage/stratisd/archive/v${pkgver}.tar.gz"
- 'initcpio-install'
- 'org.storage.stratis1.service'
- 'stratisd.service'
- 'stratisd-boot.service'
-)
-sha256sums=(
- 'ca0de355c1ae5caa562b3fae5554eb8bae8f1916b3ef7052ec5d88037eaf0458'
- 'e12069c231c3f7c6e16b347ffcddb5cf919c9e5105c56a7b9a994e1adc49da25'
- '72ab992ff564d4dd6f0290bd12e973268e45ac0b154e4695796e9737ffed31fe'
- '2143a3f942a3c2975a006c96ec78cf960417943a2425b564f91425f3a50a7ccd'
- 'cf2a2ed28cdcfa2a3b90b63a50a6ab8ca9690f8def273feab2d92d84113b931c'
-)
+makedepends=('asciidoc' 'cargo' 'rust' 'git')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/stratis-storage/stratisd/archive/v${pkgver}.tar.gz")
+sha256sums=('ca0de355c1ae5caa562b3fae5554eb8bae8f1916b3ef7052ec5d88037eaf0458')
build() {
cd "${pkgname}-${pkgver}"
- # replace service files
- cp -fT ../org.storage.stratis1.service org.storage.stratis1.service
- cp -fT ../stratisd.service stratisd.service
- cp -fT ../stratisd-boot.service stratisd-boot.service
-
# Append '--release' to `cargo build` (line 24):
sed -i 's/cargo build --target/cargo build --release --target/' Makefile
- # build standard binary (with dbus)
- msg2 "Build standard binary (dbus enabled)"
- make build
-
- # move standard binary
- mv target/x86_64-unknown-linux-gnu/release/stratisd stratisd
-
- # patch makefile to create boot build
- sed -i 's, --features "dbus_enabled",,g' Makefile
-
- # build boot binary (no dbus)
- msg2 "Build boot binary (dbus disabled)"
+ # Release
make build
+ make stratisd.8
- # move init binary
- mv target/x86_64-unknown-linux-gnu/release/stratisd stratisd-boot
-
- # build docs
- make docs
+ # patch systemd config
+ sed -i 's,/usr/libexec,/usr/bin,g' stratisd.service
}
check() {
@@ -66,34 +34,12 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
- install -d -m 755 "${pkgdir}/etc/dbus-1/system.d"
- install -d -m 755 "${pkgdir}/usr/bin"
- install -d -m 755 "${pkgdir}/usr/lib/initcpio/install"
- install -d -m 755 "${pkgdir}/usr/lib/systemd/system"
- install -d -m 755 "${pkgdir}/usr/share/dbus-1/system-services"
- install -d -m 755 "${pkgdir}/usr/share/doc"
- install -d -m 755 "${pkgdir}/usr/share/licenses/stratisd"
- install -d -m 755 "${pkgdir}/usr/share/man/man8"
-
- install -m 755 "stratisd" "${pkgdir}/usr/bin/stratisd"
- install -m 755 "stratisd-boot" "${pkgdir}/usr/bin/stratisd-boot"
- install -m 644 stratisd.service "${pkgdir}/usr/lib/systemd/system"
- install -m 644 stratisd-boot.service "${pkgdir}/usr/lib/systemd/system"
- install -m 644 ../initcpio-install "${pkgdir}/usr/lib/initcpio/install/stratis"
- install -m 644 org.storage.stratis1.service "${pkgdir}/usr/share/dbus-1/system-services"
- install -m 644 stratisd.conf "${pkgdir}/etc/dbus-1/system.d"
- cp -r target/doc/* "${pkgdir}/usr/share/doc/"
- install -m 644 docs/stratisd.8 "${pkgdir}/usr/share/man/man8"
- install -m 644 LICENSE "${pkgdir}/usr/share/licenses/stratisd/LICENSE"
-
- msg2 "If you are planning to boot from a stratis volume remember to make the following changes to '/etc/mkinitcpio.conf':"
- msg2 "Add 'stratis systemd' to HOOKS"
- msg2 "Remove 'udev', 'usr' and 'resume' from HOOKS"
- msg2 ""
- msg2 "Also run the following:"
- msg2 "systemctl enable stratisd.service"
- msg2 ""
- msg2 "Set your root volume to root=/dev/dm-5 in your bootloader config."
+ install -D -m755 "target/x86_64-unknown-linux-gnu/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 stratisd.service "${pkgdir}/usr/lib/systemd/system/stratisd.service"
+ install -D -m644 org.storage.stratis1.service "${pkgdir}/usr/share/dbus-1/system-services/org.storage.stratis1.service"
+ install -D -m644 stratisd.conf "${pkgdir}/etc/dbus-1/system.d/stratisd.conf"
+ install -D -m644 docs/stratisd.8 "${pkgdir}/usr/share/man/man8/stratisd.8"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim: ts=2 sw=2 et:
diff --git a/initcpio-install b/initcpio-install
deleted file mode 100644
index a65543b5c54b..000000000000
--- a/initcpio-install
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/usr/bin/bash
-
-build() {
- local mod
- local symlink
-
- # add necessary modules
- for mod in dm-mod dm-snapshot dm-mirror dm-cache dm-cache-smq dm-thin-pool xfs; do
- add_module "$mod"
- done
-
- # binaries from stratisd
- add_binary "/usr/bin/stratisd-boot"
-
- # binaries from device-mapper
- add_binary "dmsetup"
-
- # add thin-provisioning-tools
- add_binary "pdata_tools"
- for symlink in cache_{check,dump,metadata_size,repair,restore} thin_{check,delta,dump,ls,metadata_size,repair,restore,rmap,trim}; do
- add_symlink "/usr/bin/${symlink}" "pdata_tools"
- done
-
- # udev rules
- add_file "/usr/lib/udev/rules.d/10-dm.rules"
- add_file "/usr/lib/udev/rules.d/13-dm-disk.rules"
- add_file "/usr/lib/udev/rules.d/95-dm-notify.rules"
- add_file "/usr/lib/initcpio/udev/11-dm-initramfs.rules" "/usr/lib/udev/rules.d/11-dm-initramfs.rules"
-
- # add service
- add_file "/usr/lib/systemd/system/stratisd-boot.service"
-
- # enable service
- add_symlink "/var/run" "/run"
- add_symlink \
- "/etc/systemd/system/basic.target.wants/stratisd-boot.service" \
- "/usr/lib/systemd/system/stratisd-boot.service"
-}
-
-help() {
- cat <<HELPEOF
-This hook enables Stratis volumes in initramfs.
-HELPEOF
-}
-
-# vim: set ft=sh ts=4 sw=4 et:
diff --git a/org.storage.stratis1.service b/org.storage.stratis1.service
deleted file mode 100644
index e810de2a0d28..000000000000
--- a/org.storage.stratis1.service
+++ /dev/null
@@ -1,5 +0,0 @@
-[D-BUS Service]
-Name=org.storage.stratis1
-Exec=/bin/false
-User=root
-SystemdService=stratisd.service
diff --git a/stratisd-boot.service b/stratisd-boot.service
deleted file mode 100644
index 7283b259e70a..000000000000
--- a/stratisd-boot.service
+++ /dev/null
@@ -1,17 +0,0 @@
-[Unit]
-Description=Stratis boot daemon
-Documentation=man:stratisd(8)
-After=sysinit.target systed-udevd.service
-Before=basic.target
-Conflicts=stratisd.service
-DefaultDependencies=no
-
-[Service]
-ExecStart=/usr/bin/stratisd-boot --debug
-KillSignal=SIGINT
-Restart=on-abort
-StandardOutput=syslog
-StandardError=syslog
-
-[Install]
-WantedBy=basic.target
diff --git a/stratisd.service b/stratisd.service
deleted file mode 100644
index d0640f70c224..000000000000
--- a/stratisd.service
+++ /dev/null
@@ -1,17 +0,0 @@
-[Unit]
-Description=A daemon that manages a pool of block devices to create flexible file systems
-Documentation=man:stratisd(8)
-Conflicts=stratisd-boot.service
-DefaultDependencies=no
-
-[Service]
-Type=dbus
-BusName=org.storage.stratis1
-ExecStart=/usr/bin/stratisd --debug
-KillSignal=SIGINT
-Restart=on-abort
-StandardOutput=syslog
-StandardError=syslog
-
-[Install]
-WantedBy=sysinit.target