summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c083940c7e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = strawberry-qt5
+ pkgdesc = A music player aimed at audio enthusiasts and music collectors (QT5 version)
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://www.strawbs.org/
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = boost
+ makedepends = qt5-tools
+ depends = chromaprint
+ depends = protobuf
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = qt5-x11extras
+ depends = udisks2
+ depends = libcdio
+ depends = libgpod
+ depends = libmtp
+ depends = fftw
+ optdepends = gst-libav: additional codecs
+ optdepends = gst-plugins-bad: additional codecs
+ optdepends = gst-plugins-ugly: additional codecs
+ conflicts = strawberry
+ source = https://github.com/jonaski/strawberry/releases/download/0.9.1/strawberry-0.9.1.tar.xz
+ sha256sums = b71da4cec9cc7b60961bbb82378d15fb79798e6b880852414ce05276084047a0
+
+pkgname = strawberry-qt5
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..973e55a05b15
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+
+*.pkg.tar.zst
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21e01e047d15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Michał Przybyś <michal@przybys.eu>
+pkgname=strawberry-qt5
+pkgver=0.9.1
+pkgrel=1
+pkgdesc='A music player aimed at audio enthusiasts and music collectors (QT5 version)'
+arch=(x86_64)
+url='https://www.strawbs.org/'
+license=(GPL3)
+depends=(chromaprint
+ protobuf
+ gst-plugins-base
+ gst-plugins-good
+ qt5-x11extras
+ udisks2
+ libcdio
+ libgpod
+ libmtp
+ fftw)
+conflicts=(strawberry)
+makedepends=(cmake
+ boost
+ qt5-tools)
+optdepends=('gst-libav: additional codecs'
+ 'gst-plugins-bad: additional codecs'
+ 'gst-plugins-ugly: additional codecs')
+source=("https://github.com/jonaski/strawberry/releases/download/${pkgver}/strawberry-${pkgver}.tar.xz")
+sha256sums=(b71da4cec9cc7b60961bbb82378d15fb79798e6b880852414ce05276084047a0)
+
+build() {
+ cmake -B build -S "strawberry-${pkgver}" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install build
+}