summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c81dc747131e..60ecd9d33285 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = streamlink-git
pkgdesc = CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)
- pkgver = 5.2.1.r38.g1d525705
+ pkgver = 5.5.1.r98.g9edc4245
pkgrel = 1
url = https://streamlink.github.io/
arch = any
@@ -9,6 +9,7 @@ pkgbase = streamlink-git
checkdepends = python-pytest
checkdepends = python-pytest-asyncio
checkdepends = python-pytest-cov
+ checkdepends = python-pytest-trio
checkdepends = python-requests-mock
makedepends = python-myst-parser
makedepends = python-setuptools
@@ -23,6 +24,9 @@ pkgbase = streamlink-git
depends = python-pycryptodome
depends = python-pysocks
depends = python-requests
+ depends = python-trio
+ depends = python-trio-websocket
+ depends = python-typing_extensions
depends = python-websocket-client
optdepends = ffmpeg: Required to play streams that are made up of separate audio and video streams, eg. YouTube 1080p+
provides = streamlink
diff --git a/PKGBUILD b/PKGBUILD
index a18f0097d396..932cbc5af775 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=streamlink-git
-pkgver=5.2.1.r38.g1d525705
+pkgver=5.5.1.r98.g9edc4245
pkgrel=1
pkgdesc='CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)'
arch=('any')
url='https://streamlink.github.io/'
license=('BSD')
-depends=("python-"{certifi,isodate,pycountry,pycryptodome,pysocks,requests,websocket-client})
-checkdepends=("python-"{freezegun,pytest,pytest-asyncio,pytest-cov,requests-mock})
+depends=("python-"{certifi,isodate,pycountry,pycryptodome,pysocks,requests,trio,trio-websocket,typing_extensions,websocket-client})
+checkdepends=("python-"{freezegun,pytest,pytest-asyncio,pytest-cov,pytest-trio,requests-mock})
makedepends=("python-"{myst-parser,setuptools,sphinx,sphinx_design,shtab,versioningit} 'git')
optdepends=('ffmpeg: Required to play streams that are made up of separate audio and video streams, eg. YouTube 1080p+')
provides=("${pkgname%-*}")