summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffcf840bd712..3ee258afff6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = streamlink-git
pkgdesc = CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)
- pkgver = 0.1.0.r20.g2808eb6
+ pkgver = 0.1.0.r35.g2b052ad
pkgrel = 1
url = https://streamlink.github.io/
arch = any
license = BSD
+ checkdepends = python-pytest
makedepends = git
makedepends = python-sphinx
depends = python-pycryptodome
diff --git a/PKGBUILD b/PKGBUILD
index 27fcf5a32a93..dd306948a361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=streamlink-git
-pkgver=0.1.0.r20.g2808eb6
+pkgver=0.1.0.r35.g2b052ad
pkgrel=1
pkgdesc='CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)'
arch=('any')
url='https://streamlink.github.io/'
license=('BSD')
depends=('python-pycryptodome' 'python-requests' 'python-setuptools' 'rtmpdump')
+checkdepends=('python-pytest')
makedepends=('git' 'python-sphinx')
optdepends=('python-librtmp: Required by the ustreamtv plugin to be able to use non-mobile streams.')
provides=('streamlink')
@@ -22,10 +23,14 @@ pkgver() {
build() {
cd streamlink
- sed -i 's/requests>=1.0,<2.12.0/requests>=1.0,<3.0/' setup.py
python setup.py build_sphinx -b man
}
+check() {
+ cd streamlink
+ python -m pytest tests/
+}
+
package() {
cd streamlink
python setup.py install --root="$pkgdir" --optimize=1