summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc8dace795e0..67aaaadda643 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = streamlink-git
pkgdesc = CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)
pkgver = 0.3.0.r18.g6400e04
- pkgrel = 1
+ pkgrel = 2
url = https://streamlink.github.io/
arch = any
license = BSD
@@ -12,7 +12,7 @@ pkgbase = streamlink-git
makedepends = python-sphinx
depends = python-iso3166
depends = python-iso639
- depends = python-pycryptodome
+ depends = python-crypto
depends = python-requests
depends = rtmpdump
optdepends = ffmpeg: Required to play streams that are made up of separate audio and video streams, eg. YouTube 1080p+
@@ -20,7 +20,9 @@ pkgbase = streamlink-git
provides = streamlink
conflicts = streamlink
source = git+https://github.com/streamlink/streamlink.git
- sha256sums = SKIP
+ source = https://src.fedoraproject.org/cgit/rpms/python-streamlink.git/plain/python-streamlink-0.3.0-pycrypto.patch
+ sha512sums = SKIP
+ sha512sums = 1c25435d71555f3e077a36ff203e1259d8a9921a6ec1b4c4c152a0330bf69f4961eeece15a968819967d6acdc6365736620a6a3d69348cf9f06d38efbe6fdcb3
pkgname = streamlink-git
diff --git a/PKGBUILD b/PKGBUILD
index 77259c578e60..8b682b807871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,33 @@
pkgname=streamlink-git
pkgver=0.3.0.r18.g6400e04
-pkgrel=1
+pkgrel=2
pkgdesc='CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)'
arch=('any')
url='https://streamlink.github.io/'
license=('BSD')
-depends=("python-"{iso3166,iso639,pycryptodome,requests} 'rtmpdump')
+depends=("python-"{iso3166,iso639,crypto,requests} 'rtmpdump')
checkdepends=("python-"{mock,pytest})
makedepends=('git' "python-"{setuptools,sphinx})
optdepends=('ffmpeg: Required to play streams that are made up of separate audio and video streams, eg. YouTube 1080p+'
'python-librtmp: Required by the ustreamtv plugin to be able to use non-mobile streams.')
provides=('streamlink')
conflicts=('streamlink')
-source=('git+https://github.com/streamlink/streamlink.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/streamlink/streamlink.git'
+ 'https://src.fedoraproject.org/cgit/rpms/python-streamlink.git/plain/python-streamlink-0.3.0-pycrypto.patch')
+sha512sums=('SKIP'
+ '1c25435d71555f3e077a36ff203e1259d8a9921a6ec1b4c4c152a0330bf69f4961eeece15a968819967d6acdc6365736620a6a3d69348cf9f06d38efbe6fdcb3')
pkgver() {
cd streamlink
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd streamlink
+ patch -p1 < ../python-streamlink-0.3.0-pycrypto.patch
+}
+
build() {
cd streamlink
python setup.py build_sphinx -b man