summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 4 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3a56c9c1a84..b2b5d4efc81f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = streem-git
pkgdesc = prototype of stream based programming language
- pkgver = r940.c7214e5
+ pkgver = r942.4d79ff2
pkgrel = 1
url = https://github.com/matz/streem
arch = x86_64
@@ -10,9 +10,7 @@ pkgbase = streem-git
provides = streem
conflicts = streem
source = git+https://github.com/matz/streem.git
- source = streem-git-164.patch::https://github.com/matz/streem/pull/164.patch
md5sums = SKIP
- md5sums = d285857bd0804471aa6560ccf4f2e295
pkgname = streem-git
diff --git a/PKGBUILD b/PKGBUILD
index 71eb7d33aaf6..785bfeb923cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname="streem"
pkgname=("${_pkgname}-git")
-pkgver=r940.c7214e5
+pkgver=r942.4d79ff2
pkgrel=1
pkgdesc='prototype of stream based programming language'
arch=('x86_64')
@@ -12,22 +12,14 @@ provides=('streem')
conflicts=('streem')
depends=('glibc')
makedepends=('git')
-source=('git+https://github.com/matz/streem.git'
- "${pkgname}-164.patch::https://github.com/matz/streem/pull/164.patch")
-md5sums=('SKIP'
- 'd285857bd0804471aa6560ccf4f2e295')
+source=('git+https://github.com/matz/streem.git')
+md5sums=('SKIP')
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${_pkgname}"
-
- patch src/Makefile "${srcdir}/${pkgname}-164.patch"
-}
-
build() {
cd "${_pkgname}"