summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--010-stremio-do-not-download-server-js.patch (renamed from stremio-do-not-download-server-js.patch)13
-rw-r--r--PKGBUILD57
3 files changed, 49 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a97bd39f3a4..be6e050a383b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,37 @@
pkgbase = stremio
pkgdesc = A one-stop hub for video content aggregation (Movies, TV shows, series, live television or web channels)
- pkgver = 4.4.77
- pkgrel = 2
+ pkgver = 4.4.165
+ pkgrel = 1
url = https://www.stremio.com/
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = cmake
makedepends = librsvg
depends = mpv
- depends = qt5-webengine
+ depends = nodejs
+ depends = openssl
+ depends = qt5-base
depends = qt5-declarative
- depends = qt5-webchannel
+ depends = qt5-webengine
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
depends = qt5-translations
- depends = nodejs
- source = git+https://github.com/Stremio/stremio-shell.git#tag=4.4.77
+ depends = qt5-webchannel
+ depends = hicolor-icon-theme
+ source = git+https://github.com/Stremio/stremio-shell.git#tag=v4.4.165
source = git+https://github.com/Ivshti/libmpv.git
source = git+https://github.com/itay-grudev/SingleApplication.git
source = git+https://github.com/Ivshti/razerchroma.git
- source = stremio-4.4.77-server.js::https://dl.strem.io/four/v4.4.77/server.js
- source = stremio-4.4.77-stremio.asar::https://dl.strem.io/four/v4.4.77/stremio.asar
- source = stremio-do-not-download-server-js.patch
+ source = stremio-4.4.165-server.js::https://dl.strem.io/four/v4.4.165/server.js
+ source = stremio-4.4.165-stremio.asar::https://dl.strem.io/four/v4.4.165/stremio.asar
+ source = 010-stremio-do-not-download-server-js.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 2ccab494d975363fd16b61d51527995c7d452d66e69dd1bd9ffa2a4d11fb7191
- sha256sums = e2295734bb6ff6ecf9b1fd423f89fccc617a11a86310bf44b03301f452650067
- sha256sums = b1febe31374eaceefc1f869d574a00f7f5414eafa8b5d0a92a5f511078ba3add
+ sha256sums = e763e0d0fad5d796ab1aa843deb5d80a5d49ea47282fefc11d1be089004efce0
+ sha256sums = 4c74af8bf77ddc2b278c623a5f2d019e416439e1b83666cc850b730bc02acd20
+ sha256sums = b5eff88b30d8c6030e36ca4949ebf6ff9515efbedc0b9bc748110cd1fbc0671a
pkgname = stremio
-
diff --git a/stremio-do-not-download-server-js.patch b/010-stremio-do-not-download-server-js.patch
index 21705fd3be63..1beffd79e58b 100644
--- a/stremio-do-not-download-server-js.patch
+++ b/010-stremio-do-not-download-server-js.patch
@@ -1,6 +1,5 @@
-diff -Naurp a/release.makefile b/release.makefile
---- a/release.makefile 2019-06-01 17:55:19.000000000 +0000
-+++ b/release.makefile 2019-06-01 17:58:39.254503016 +0000
+--- a/release.makefile
++++ b/release.makefile
@@ -8,7 +8,7 @@ SERVER_JS := server.js
STREMIO_BIN := ${BUILD_DIR}/stremio
@@ -10,16 +9,16 @@ diff -Naurp a/release.makefile b/release.makefile
install:
make -C ${BUILD_DIR} install
-@@ -24,14 +24,11 @@ icons:
+@@ -28,14 +28,11 @@ icons:
mkdir -p "$@"
cd "$@" && printf 16,22,24,32,64,128 | xargs -I^ -d, sh -c 'rsvg-convert ../images/stremio.svg -w ^ -o smartcode-stremio_^.png && rsvg-convert ../images/stremio_tray_white.svg -w ^ -o smartcode-stremio-tray_^.png'
--${SERVER_JS}:
-- wget "https://s3-eu-west-1.amazonaws.com/stremio-artifacts/four/master/server.js" -qO ${SERVER_JS} || rm ${SERVER_JS}
+-${SERVER_JS}:
+- wget "${shell cat server-url.txt}" -qO ${SERVER_JS} || rm ${SERVER_JS}
-
${STREMIO_BIN}:
mkdir -p ${BUILD_DIR}
- cd ${BUILD_DIR} && qmake PREFIX="${PREFIX}" ..
+ cd ${BUILD_DIR} && cmake -G"Unix Makefiles" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${PREFIX}" ..
make -j -C ${BUILD_DIR}
clean:
diff --git a/PKGBUILD b/PKGBUILD
index 18c34ffa7f78..99ad3d02a027 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,53 @@
-# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=stremio
-pkgver=4.4.77
-pkgrel=2
+pkgver=4.4.165
+pkgrel=1
pkgdesc='A one-stop hub for video content aggregation (Movies, TV shows, series, live television or web channels)'
arch=('x86_64')
url='https://www.stremio.com/'
license=('GPL3')
-depends=('mpv' 'qt5-webengine' 'qt5-declarative' 'qt5-webchannel' 'qt5-quickcontrols'
- 'qt5-quickcontrols2' 'qt5-translations' 'nodejs')
-makedepends=('git' 'librsvg')
-source=("git+https://github.com/Stremio/stremio-shell.git#tag=${pkgver}"
+depends=('mpv' 'nodejs' 'openssl' 'qt5-base' 'qt5-declarative' 'qt5-webengine'
+ 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-translations' 'qt5-webchannel'
+ 'hicolor-icon-theme')
+makedepends=('git' 'cmake' 'librsvg')
+source=("git+https://github.com/Stremio/stremio-shell.git#tag=v${pkgver}"
'git+https://github.com/Ivshti/libmpv.git'
'git+https://github.com/itay-grudev/SingleApplication.git'
'git+https://github.com/Ivshti/razerchroma.git'
"stremio-${pkgver}-server.js"::"https://dl.strem.io/four/v${pkgver}/server.js"
"stremio-${pkgver}-stremio.asar"::"https://dl.strem.io/four/v${pkgver}/stremio.asar"
- 'stremio-do-not-download-server-js.patch')
+ '010-stremio-do-not-download-server-js.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '2ccab494d975363fd16b61d51527995c7d452d66e69dd1bd9ffa2a4d11fb7191'
- 'e2295734bb6ff6ecf9b1fd423f89fccc617a11a86310bf44b03301f452650067'
- 'b1febe31374eaceefc1f869d574a00f7f5414eafa8b5d0a92a5f511078ba3add')
+ 'e763e0d0fad5d796ab1aa843deb5d80a5d49ea47282fefc11d1be089004efce0'
+ '4c74af8bf77ddc2b278c623a5f2d019e416439e1b83666cc850b730bc02acd20'
+ 'b5eff88b30d8c6030e36ca4949ebf6ff9515efbedc0b9bc748110cd1fbc0671a')
prepare() {
- cd stremio-shell
-
- git submodule init
- git config --local submodule.deps/libmpv.url "${srcdir}/libmpv"
- git config --local submodule.deps/singleapplication.url "${srcdir}/SingleApplication"
- git config --local submodule.deps/chroma.url "${srcdir}/razerchroma"
- git submodule update
+ git -C stremio-shell submodule init
+ git -C stremio-shell config --local submodule.deps/libmpv.url "${srcdir}/libmpv"
+ git -C stremio-shell config --local submodule.deps/singleapplication.url "${srcdir}/SingleApplication"
+ git -C stremio-shell config --local submodule.deps/chroma.url "${srcdir}/razerchroma"
+ git -C stremio-shell -c protocol.file.allow='always' submodule update
# do not download server.js during 'make'
- ln -s "${srcdir}/stremio-${pkgver}-server.js" server.js
- patch -Np1 -i "${srcdir}/stremio-do-not-download-server-js.patch"
+ ln -s "../stremio-${pkgver}-server.js" stremio-shell/server.js
+ patch -d stremio-shell -Np1 -i "${srcdir}/010-stremio-do-not-download-server-js.patch"
}
build() {
- cd stremio-shell
-
- make -f release.makefile PREFIX="$pkgdir"
+ make -C stremio-shell -f release.makefile PREFIX="$pkgdir"
}
package() {
- cd stremio-shell
-
- make -f release.makefile PREFIX="$pkgdir" install
+ make -C stremio-shell -f release.makefile PREFIX="$pkgdir" install
# streaming server files
- install -D -m644 "${srcdir}/stremio-${pkgver}-server.js" "${pkgdir}/opt/stremio/server.js"
- install -D -m644 "${srcdir}/stremio-${pkgver}-stremio.asar" "${pkgdir}/opt/stremio/stremio.asar"
+ install -D -m644 "stremio-${pkgver}-server.js" "${pkgdir}/opt/stremio/server.js"
+ install -D -m644 "stremio-${pkgver}-stremio.asar" "${pkgdir}/opt/stremio/stremio.asar"
# binary and desktop file
mkdir -p "${pkgdir}/usr/"{bin,share/applications}
@@ -60,13 +55,15 @@ package() {
ln -s ../../../opt/stremio/smartcode-stremio.desktop "${pkgdir}/usr/share/applications/smartcode-stremio.desktop"
# icons
+ local _file
local _res
- for _res in 16 22 24 32 64 128
+ while read -r -d '' _file
do
+ _res="$(printf '%s' "$_file" | sed 's/\.png$//;s/^.*_//')"
mkdir -p "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps"
ln -s ../../../../../../opt/stremio/icons/smartcode-stremio_${_res}.png \
"${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/smartcode-stremio.png"
ln -s ../../../../../../opt/stremio/icons/smartcode-stremio-tray_${_res}.png \
"${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/smartcode-stremio-tray.png"
- done
+ done < <(find "${pkgdir}/opt/stremio/icons" -maxdepth 1 -type f -name 'smartcode-stremio_*.png' -print0)
}