summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--467.patch24
-rw-r--r--PKGBUILD12
3 files changed, 8 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec296bebfb0b..21ef85b9e4b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = stripe-cli
pkgdesc = CLI for Stripe
- pkgver = 1.5.0
- pkgrel = 2
+ pkgver = 1.5.2
+ pkgrel = 1
url = https://stripe.com/docs/stripe-cli
arch = x86_64
license = Apache
makedepends = go
depends = glibc
- source = stripe-cli-1.5.0.tar.gz::https://github.com/stripe/stripe-cli/archive/v1.5.0.tar.gz
+ source = stripe-cli-1.5.2.tar.gz::https://github.com/stripe/stripe-cli/archive/v1.5.2.tar.gz
source = reproducible-image-flags.patch
- source = 467.patch
- sha512sums = fd41054a4047dff23d16243ffe4b49b774214d37827490f774c7309d8a487a7018c5aa708ff7f36b5d572a1b3ecd1c7538fdd9a982a403da041c8843e9c70c23
+ sha512sums = a5d7938b8846fffcd6bd2eea0fc710b589b3f81dc5f23990eb1b3c415474528e7a0e7172844064e2a0e88fb40f39d6743230b3405698121e187b2a846edafea2
sha512sums = 4f5ff8662f5e4bce1ded88a055e652c41dd6492cda5aee74795752abf0e97cc269ec1fef84df2247f62809f0c8cc1a88dd12104e07090cc224bbc5ad46b33f37
- sha512sums = 74561fa2d5e9a6b421ced78b04d426a8e54c7a254b3bde3c61e9c7b67c2f40c298b83211f0fb17ad576ee8cecc67ea2d3138c7178a711a7feb863907a9e4a256
pkgname = stripe-cli
diff --git a/467.patch b/467.patch
deleted file mode 100644
index bf63dc83eb51..000000000000
--- a/467.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 908f7ecc8bba4602ba21a8c9376a53d6f2906b51 Mon Sep 17 00:00:00 2001
-From: Sam Whited <sam@samwhited.com>
-Date: Tue, 16 Jun 2020 12:27:37 -0400
-Subject: [PATCH] Fix int/string conversion in error message
-
-In Go 1.14 this would do the wrong thing silently, but this will cause
-tests to fail on Go 1.15.
----
- pkg/fixtures/fixtures.go | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pkg/fixtures/fixtures.go b/pkg/fixtures/fixtures.go
-index 83bc1072..3c04ad03 100644
---- a/pkg/fixtures/fixtures.go
-+++ b/pkg/fixtures/fixtures.go
-@@ -95,7 +95,7 @@ func NewFixture(fs afero.Fs, apiKey, stripeAccount, baseURL, file string) (*Fixt
- }
-
- if fxt.fixture.Meta.Version > SupportedVersions {
-- return nil, fmt.Errorf("Fixture version not supported: %s", string(fxt.fixture.Meta.Version))
-+ return nil, fmt.Errorf("Fixture version not supported: %d", fxt.fixture.Meta.Version)
- }
-
- return &fxt, nil
diff --git a/PKGBUILD b/PKGBUILD
index 6499d280776c..a380ef260770 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Sam Whited <sam@samwhited.com>
pkgname=stripe-cli
-pkgver=1.5.0
-pkgrel=2
+pkgver=1.5.2
+pkgrel=1
pkgdesc='CLI for Stripe'
arch=(x86_64)
url=https://stripe.com/docs/stripe-cli
@@ -14,19 +14,15 @@ makedepends=(go)
source=(
$pkgname-$pkgver.tar.gz::https://github.com/stripe/stripe-cli/archive/v$pkgver.tar.gz
reproducible-image-flags.patch
- 467.patch
)
-sha512sums=('fd41054a4047dff23d16243ffe4b49b774214d37827490f774c7309d8a487a7018c5aa708ff7f36b5d572a1b3ecd1c7538fdd9a982a403da041c8843e9c70c23'
- '4f5ff8662f5e4bce1ded88a055e652c41dd6492cda5aee74795752abf0e97cc269ec1fef84df2247f62809f0c8cc1a88dd12104e07090cc224bbc5ad46b33f37'
- '74561fa2d5e9a6b421ced78b04d426a8e54c7a254b3bde3c61e9c7b67c2f40c298b83211f0fb17ad576ee8cecc67ea2d3138c7178a711a7feb863907a9e4a256')
+sha512sums=('a5d7938b8846fffcd6bd2eea0fc710b589b3f81dc5f23990eb1b3c415474528e7a0e7172844064e2a0e88fb40f39d6743230b3405698121e187b2a846edafea2'
+ '4f5ff8662f5e4bce1ded88a055e652c41dd6492cda5aee74795752abf0e97cc269ec1fef84df2247f62809f0c8cc1a88dd12104e07090cc224bbc5ad46b33f37')
prepare() {
cd $pkgname-$pkgver
# Add reproducible image flags
patch -Np0 < ../reproducible-image-flags.patch
- # Patch tests for Go 1.15
- patch -Np1 < ../467.patch
make setup
}