summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD1
-rw-r--r--style50.install16
4 files changed, 19 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a27629b69cd..7a671add7bb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = style50
pkgver = 2.7.4
pkgrel = 1
url = https://github.com/cs50/style50
+ install = style50.install
arch = any
groups = cs50
license = GPL
diff --git a/.gitignore b/.gitignore
index 1ad6a70db140..b46db160518a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.SRCINFO
!.gitignore
!PKGBUILD
+!style50.install
diff --git a/PKGBUILD b/PKGBUILD
index 415ef7398c57..6b67f5d90b98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,7 @@ license=('GPL')
groups=('cs50')
depends=('python' 'autopep8' 'icdiff' 'python-argparse' 'python-jsbeautifier' 'python-termcolor')
makedepends=('python-setuptools')
+install=${pkgname}.install
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
sha256sums=('6bee9cd5b7a02242a627a472b8618768f83c654f4b507f4c2b047437630266c3')
diff --git a/style50.install b/style50.install
new file mode 100644
index 000000000000..b5e8283d1417
--- /dev/null
+++ b/style50.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -e "********************************************"
+ echo -e "If run into issue with icdiff like so:"
+ echo -e "pkg_resources.DistributionNotFound: The 'icdiff' distribution was not found and is required by style50"
+ echo -e "\n"
+ echo -e "Then install icdiff like so:"
+ echo -e "pip install --user icdiff"
+ echo -e "\n"
+ echo -e "This issue has been reported to the AUR maintainer of icdiff"
+ echo -e "********************************************"
+ echo -e -n ""
+}
+
+post_upgrade() {
+ post_install
+}