summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29a2ebda858a..f766ffdfa98f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = stylelint
- pkgdesc = A mighty, modern CSS linter that helps you enforce consistent conventions and avoid errors in your stylesheets
- pkgver = 9.10.1
+ pkgdesc = A linter for CSS-like syntaxes like SCSS, Sass, Less and SugarSS
+ pkgver = 13.3.3
pkgrel = 1
url = https://stylelint.io/
arch = any
license = MIT
makedepends = npm
depends = nodejs
- optdepends = stylelint-config-standard
- noextract = stylelint-9.10.1.tgz
- source = https://registry.npmjs.org/stylelint/-/stylelint-9.10.1.tgz
- sha512sums = f54887c5984e007120790ee82c6c2bc280d1f2f72504a9525fbaf87c7d22baed127cfc0568b91bd5ced0da3d5caa0f4fec80d77805764ef40c2ff7d143318105
+ optdepends = stylelint-config-standard: config for common conventions
+ noextract = stylelint-13.3.3.tgz
+ source = https://registry.npmjs.org/stylelint/-/stylelint-13.3.3.tgz
+ sha256sums = 7691a41622514d9b8298511907c7b58e5d83aeeba63482481706c21294d34085
pkgname = stylelint
diff --git a/PKGBUILD b/PKGBUILD
index 630d1b32173e..716278d9a6c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
# Maintainer: Stijn Seghers <stijnseghers at gmail dot com>
pkgname=stylelint
-pkgver=9.10.1
+pkgver=13.3.3
pkgrel=1
-pkgdesc='A mighty, modern CSS linter that helps you enforce consistent conventions and avoid errors in your stylesheets'
+pkgdesc='A linter for CSS-like syntaxes like SCSS, Sass, Less and SugarSS'
arch=('any')
url='https://stylelint.io/'
license=('MIT')
depends=('nodejs')
-optdepends=('stylelint-config-standard')
+optdepends=('stylelint-config-standard: config for common conventions')
makedepends=('npm')
source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
noextract=("$pkgname-$pkgver.tgz")
-sha512sums=('f54887c5984e007120790ee82c6c2bc280d1f2f72504a9525fbaf87c7d22baed127cfc0568b91bd5ced0da3d5caa0f4fec80d77805764ef40c2ff7d143318105')
+sha256sums=('7691a41622514d9b8298511907c7b58e5d83aeeba63482481706c21294d34085')
package() {
- npm install -g --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
+ npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
- # For some odd reason, npm makes some directories world writeable D:
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/npm/issues/9359 for details.
find "$pkgdir/usr" -type d -exec chmod 755 {} +
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "$pkgdir"
+
# Install license in the usual place
local _npmdir="$pkgdir/usr/lib/node_modules/"
install -Dm644 "$_npmdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"