summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD14
3 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72c72dd914fb..ce05786ecc66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stylelint
pkgdesc = A mighty, modern CSS linter that helps you enforce consistent conventions and avoid errors in your stylesheets
- pkgver = 9.0.0
+ pkgver = 9.3.0
pkgrel = 1
url = https://stylelint.io/
arch = any
@@ -8,9 +8,9 @@ pkgbase = stylelint
makedepends = npm
depends = nodejs
optdepends = stylelint-config-standard
- noextract = stylelint-9.0.0.tgz
- source = https://registry.npmjs.org/stylelint/-/stylelint-9.0.0.tgz
- sha512sums = 49642d753dd10494b0fbcc4896d06b25f6982c8a85660ada1c08736f22a9fe5c81f84a5ba9f0fbb7188451ea2c54e1fa483d4c39f84558a811aee7b29a58c5b2
+ noextract = stylelint-9.3.0.tgz
+ source = https://registry.npmjs.org/stylelint/-/stylelint-9.3.0.tgz
+ sha512sums = bb9f6959396b7708eaae226d4ef3b56b4c112b599f6d0429ee32eddbb497e339761e6b551ce33f235c1de37c474ef5096432a9d4f4cea6a4406a6537805be638
pkgname = stylelint
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fad592fca792
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.xz
+*.tgz
diff --git a/PKGBUILD b/PKGBUILD
index 62792f41cfb2..37970eb07b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stijn Seghers <stijnseghers at gmail dot com>
pkgname=stylelint
-pkgver=9.0.0
+pkgver=9.3.0
pkgrel=1
pkgdesc='A mighty, modern CSS linter that helps you enforce consistent conventions and avoid errors in your stylesheets'
arch=('any')
@@ -12,13 +12,15 @@ optdepends=('stylelint-config-standard')
makedepends=('npm')
source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
noextract=("$pkgname-$pkgver.tgz")
-sha512sums=('49642d753dd10494b0fbcc4896d06b25f6982c8a85660ada1c08736f22a9fe5c81f84a5ba9f0fbb7188451ea2c54e1fa483d4c39f84558a811aee7b29a58c5b2')
+sha512sums=('bb9f6959396b7708eaae226d4ef3b56b4c112b599f6d0429ee32eddbb497e339761e6b551ce33f235c1de37c474ef5096432a9d4f4cea6a4406a6537805be638')
package() {
- npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
+ npm install -g --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
- rm -r "$pkgdir/usr/etc"
+ # For some odd reason, npm makes some directories world writeable D:
+ find "$pkgdir/usr" -type d -exec chmod 755 {} +
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- ln -s "../../../lib/node_modules/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Install license in the usual place
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ install -Dm644 "$_npmdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}