summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x[-rw-r--r--].SRCINFO14
-rwxr-xr-x[-rw-r--r--]PKGBUILD44
-rw-r--r--substance-designer11
-rw-r--r--substance-designer-icon.pngbin6463 -> 0 bytes
-rw-r--r--substance-designer.desktop11
5 files changed, 23 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8358acf7b498..fcb3a0bdb39f 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = substance-designer
pkgdesc = Node-based, non-destructive PBR material authoring tool.
- pkgver = 2019.2.2
+ pkgver = 12.2.1
pkgrel = 1
url = https://www.allegorithmic.com/products/substance-designer
arch = x86_64
@@ -10,15 +10,9 @@ pkgbase = substance-designer
depends = glu
depends = hicolor-icon-theme
depends = libtiff4
+ depends = libxcrypt-compat
options = !strip
- source = https://download.allegorithmic.com/substance-designer/2019.x/Substance_Designer-2019.2.2-2644-linux-x64-standard-full.rpm
- source = substance-designer-icon.png
- source = substance-designer.desktop
- source = substance-designer
- sha256sums = e9753b9866774ce5512000b036ac32a25abd16d2ab96a247b5befc9755924544
- sha256sums = 8f7f090d96dbb3535747d2c09c32970343c8887df610bc7ef92b59871a9bfb35
- sha256sums = 223b641960e9fab3e8ba67e171c84e91ebe6f171a748b9036e4bc97fd4ec6cae
- sha256sums = 714d4484f5ca6d1ac0de77729ab60fc6aee53a7dc217fda5a6401fb6f8eee156
+ source = https://download.substance3d.com/adobe-substance-3d-designer/12.x/Adobe_Substance_3D_Designer-12.2.1-5947-linux-x64-standard.rpm
+ sha256sums = b7c7e6cc3a8d015cda7e6d35e6c8b253219d94401887c9291684849a0f04aac6
pkgname = substance-designer
-
diff --git a/PKGBUILD b/PKGBUILD
index e0a0350ac3be..4cd7b24a3866 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,32 @@
-# Maintainer: Oscar Morante <spacepluk@gmail.com>
-# Co-maintainer: Dragoon Aethis <dragoon@dragonic.eu>
+# Maintainer: t-ask <t-ask-aur at cixera dot com>
+# Co-maintainer: lehthanis <lehthanis at gmail dot com>
+# Co-maintainer: Rain Shinotsu <Rain_Shinotsu at proton dot me>
+# Contributor: Oscar Morante <spacepluk at gmail dot com>
+# Contributor: Dragoon Aethis <dragoon at dragonic dot eu>
pkgname=substance-designer
-pkgver=2019.2.2
-_build=2644
+pkgver=12.2.1
pkgrel=1
+_build=5947
pkgdesc="Node-based, non-destructive PBR material authoring tool."
arch=('x86_64')
url='https://www.allegorithmic.com/products/substance-designer'
license=('custom')
-depends=('fontconfig' 'gcc-libs-multilib' 'glu' 'hicolor-icon-theme' 'libtiff4')
-options=('!strip')
-source=("https://download.allegorithmic.com/substance-designer/2019.x/Substance_Designer-${pkgver}-${_build}-linux-x64-standard-full.rpm"
- 'substance-designer-icon.png'
- 'substance-designer.desktop'
- 'substance-designer')
-sha256sums=('e9753b9866774ce5512000b036ac32a25abd16d2ab96a247b5befc9755924544'
- '8f7f090d96dbb3535747d2c09c32970343c8887df610bc7ef92b59871a9bfb35'
- '223b641960e9fab3e8ba67e171c84e91ebe6f171a748b9036e4bc97fd4ec6cae'
- '714d4484f5ca6d1ac0de77729ab60fc6aee53a7dc217fda5a6401fb6f8eee156')
+depends=('fontconfig' 'gcc-libs-multilib' 'glu' 'hicolor-icon-theme' 'libtiff4' 'libxcrypt-compat')
+options=('!strip') # PNG assets here should be left untouched!
+
+source=("https://download.substance3d.com/adobe-substance-3d-designer/12.x/Adobe_Substance_3D_Designer-${pkgver}-${_build}-linux-x64-standard.rpm")
+sha256sums=('b7c7e6cc3a8d015cda7e6d35e6c8b253219d94401887c9291684849a0f04aac6')
+
validpgpkeys=()
package() {
- mkdir -p ${pkgdir}/opt/Allegorithmic
- mv ${srcdir}/opt/Allegorithmic/Substance_Designer ${pkgdir}/opt/Allegorithmic
-
- install -Dm644 ${pkgdir}/opt/Allegorithmic/Substance_Designer/eula.txt \
- ${pkgdir}/usr/share/licenses/${pkgname}/eula.txt
- rm ${pkgdir}/opt/Allegorithmic/Substance_Designer/eula.txt
+ mkdir -p "${pkgdir}/opt/Adobe"
- # Workaround for https://forum.substance3d.com/index.php/topic,29285.0.html
- rm ${pkgdir}/opt/Allegorithmic/Substance_Designer/libfreetype.so.6
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/opt/Adobe/Adobe_Substance_3D_Designer/resources/adobe-Adobe_Substance_3D_Designer.desktop"
+ install -Dm644 -t "${pkgdir}/usr/share/mime/packages" "${srcdir}/opt/Adobe/Adobe_Substance_3D_Designer/resources/adobe-x.adobe.substance3d.designer.xml"
+ install -Dm644 -t "${pkgdir}/usr/share/icons" "${srcdir}/opt/Adobe/Adobe_Substance_3D_Designer/resources/icons/substance-256x256.png"
- install -Dm644 -t "${pkgdir}/usr/share/applications" "${srcdir}/substance-designer.desktop"
- install -Dm644 -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps" "${srcdir}/substance-designer-icon.png"
- install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/substance-designer"
+ mv "${pkgdir}/usr/share/icons/substance-256x256.png" "${pkgdir}/usr/share/icons/adobe-Adobe_Substance_3D_Designer.png"
+ mv "${srcdir}/opt/Adobe/Adobe_Substance_3D_Designer" "${pkgdir}/opt/Adobe/"
}
diff --git a/substance-designer b/substance-designer
deleted file mode 100644
index c21e60358e01..000000000000
--- a/substance-designer
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-# If the interface is too small/big, uncomment the following line and tweak the value accordingly.
-#export QT_SCALE_FACTOR=0.75
-
-# If you're using a Nvidia Optimus setup, uncomment the line below and comment the final line to
-# always use the Nvidia GPU for this software (which is often too heavy for integrated GPUs).
-#exec primusrun /opt/Allegorithmic/Substance_Designer/Substance\ Designer "$@"
-
-exec /opt/Allegorithmic/Substance_Designer/Substance\ Designer "$@"
-
diff --git a/substance-designer-icon.png b/substance-designer-icon.png
deleted file mode 100644
index e8eda35bbf1e..000000000000
--- a/substance-designer-icon.png
+++ /dev/null
Binary files differ
diff --git a/substance-designer.desktop b/substance-designer.desktop
deleted file mode 100644
index d3086991e544..000000000000
--- a/substance-designer.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Name=Substance Designer
-GenericName=Material Authoring Software
-Description=PBR material design and authoring tool
-Exec=/usr/bin/substance-designer
-Icon=substance-designer-icon
-Terminal=false
-Type=Application
-StartupNotify=true
-Categories=Utility;Graphics
-MimeType=application/x.allegorithmic.package+xml;application/x.allegorithmic.substance