summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD41
-rw-r--r--install12
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bf3fb004322
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = subsurface-git
+ pkgdesc = Divelog program
+ pkgver = 20150607.d9801b6
+ pkgrel = 1
+ url = http://subsurface-divelog.org/
+ install = install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = asciidoc
+ depends = libzip
+ depends = libxml2
+ depends = libxslt
+ depends = sqlite
+ depends = libusb
+ depends = libgit2
+ depends = subsurface-libdc
+ depends = subsurface-marble
+ provides = subsurface
+ conflicts = subsurface
+ source = git://git.subsurface-divelog.org/subsurface
+ sha1sums = SKIP
+
+pkgname = subsurface-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92b1165ae4c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=subsurface-git
+_pkgname=subsurface
+pkgver=20150607.d9801b6
+pkgrel=1
+pkgdesc='Divelog program'
+url='http://subsurface-divelog.org/'
+license=('GPL2')
+arch=('i686' 'x86_64')
+makedepends=('git' 'cmake' 'asciidoc')
+depends=('libzip' 'libxml2' 'libxslt' 'sqlite' 'libusb' 'libgit2'
+ 'subsurface-libdc' 'subsurface-marble')
+source=('git://git.subsurface-divelog.org/subsurface')
+sha1sums=('SKIP')
+
+install=install
+
+provides=('subsurface')
+conflicts=('subsurface')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMARBLE_INCLUDE_DIR='/usr/include/subsurface' \
+ .
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..bc2362addd77
--- /dev/null
+++ b/install
@@ -0,0 +1,12 @@
+post_upgrade() {
+ type gtk-update-icon-cache &>/dev/null &&
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ post_upgrade
+}
+
+post_remove() {
+ post_upgrade
+}