summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--remove-gpu-hwdec-interop.patch12
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 967d5019d0c4..6f59725765c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = subtitld
pkgdesc = Subtitld: An open source software to create, edit and transcribe subtitles
pkgver = 23.02
- pkgrel = 2
+ pkgrel = 3
url = https://www.subtitld.org/
arch = any
license = GPL3
@@ -31,6 +31,8 @@ pkgbase = subtitld
depends = python-chardet
depends = hicolor-icon-theme
source = https://gitlab.com/jonata/subtitld/-/archive/23.02/subtitld-23.02.tar.gz
+ source = remove-gpu-hwdec-interop.patch
sha256sums = 83381cd697fa4355bc0d4689dfc063efe9ec41c8e177b8e55e35b7b4e6af3ace
+ sha256sums = fe4288ee0bbde13e4cf20f9c55c7bc973e8928fd37da50b2c05038205ecf20d5
pkgname = subtitld
diff --git a/PKGBUILD b/PKGBUILD
index b3a98c6614b9..a60a33b24fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='subtitld'
pkgver=23.02
-pkgrel=2
+pkgrel=3
pkgdesc='Subtitld: An open source software to create, edit and transcribe subtitles'
arch=('any')
url='https://www.subtitld.org/'
@@ -15,8 +15,15 @@ depends=('python' 'pyside6' 'python-pyffms2' 'python-mpv'
'python-beautifulsoup4' 'python-lxml' 'python-six' 'python-chardet'
'hicolor-icon-theme'
)
-source=("https://gitlab.com/jonata/$pkgname/-/archive/$pkgver/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('83381cd697fa4355bc0d4689dfc063efe9ec41c8e177b8e55e35b7b4e6af3ace')
+source=("https://gitlab.com/jonata/$pkgname/-/archive/$pkgver/${pkgname}-${pkgver}.tar.gz"
+ "remove-gpu-hwdec-interop.patch")
+sha256sums=('83381cd697fa4355bc0d4689dfc063efe9ec41c8e177b8e55e35b7b4e6af3ace'
+ 'fe4288ee0bbde13e4cf20f9c55c7bc973e8928fd37da50b2c05038205ecf20d5')
+
+prepare() {
+ cd ${pkgname}-${pkgver}/
+ patch -p1 < ../remove-gpu-hwdec-interop.patch
+}
build() {
cd ${pkgname}-${pkgver}/
diff --git a/remove-gpu-hwdec-interop.patch b/remove-gpu-hwdec-interop.patch
new file mode 100644
index 000000000000..6fcddaeb7792
--- /dev/null
+++ b/remove-gpu-hwdec-interop.patch
@@ -0,0 +1,12 @@
+--- subtitld-23.02.orig/subtitld/interface/player.py 2023-03-13 20:38:33.000000000 +0100
++++ subtitld-23.02/subtitld/interface/player.py 2023-11-17 18:36:20.869500323 +0100
+@@ -69,9 +69,6 @@
+ # "gpu-context": "x11egl"
+ }
+
+- if not ACTUAL_OS == 'windows':
+- options["gpu-hwdec-interop"] = "vaapi-egl"
+-
+ for key, value in options.items():
+ setattr(widget.mpv, key, value)
+