summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD24
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff1222298296
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = summovie
+ pkgdesc = Calculates electron microscopy movie frame sums using alignment results from Unblur
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://grigoriefflab.janelia.org/unblur
+ arch = x86_64
+ license = custom
+ depends = unblur
+ source = http://grigoriefflab.janelia.org/sites/all/modules/pubdnldcnt/pubdnldcnt.php?file=http://grigoriefflab.janelia.org/sites/default/files/summovie_1.0.2.tar.gz
+ source = LICENSE
+ md5sums = 170b42d194c20d66b5de7d09e574bb89
+ md5sums = SKIP
+
+pkgname = summovie
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9d8c11215816
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The Janelia Farm Research Campus Software Copyright 1.1
+
+Copyright (c) 2014, Howard Hughes Medical Institute, All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that
+the following conditions are met:
+
+Redistributions of source code must retain the above copyright notice, this list of conditions and the
+following disclaimer.
+Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
+following disclaimer in the documentation and/or other materials provided with the distribution.
+Neither the name of the Howard Hughes Medical Institute nor the names of its contributors may be used to
+endorse or promote products derived from this software without specific prior written permission.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
+WARRANTIES, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, OR
+FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; REASONABLE ROYALTIES;
+OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
+EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df16215ed670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Joshua Hardy <joshinsilico@gmail.com>
+pkgname=summovie
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Calculates electron microscopy movie frame sums using alignment results from Unblur"
+arch=(x86_64)
+url="http://grigoriefflab.janelia.org/unblur"
+license=('custom')
+depends=('unblur')
+optdepends=()
+source=("http://grigoriefflab.janelia.org/sites/all/modules/pubdnldcnt/pubdnldcnt.php?file=http://grigoriefflab.janelia.org/sites/default/files/summovie_${pkgver}.tar.gz" "LICENSE")
+md5sums=('170b42d194c20d66b5de7d09e574bb89' 'SKIP')
+options=()
+
+prepare () {
+ echo "Summovie was written by Timothy Grant and Alexis Rohou and is subject to Janelia Farm Research Campus Software Copyright 1.1."
+}
+
+package() {
+ cd "${srcdir}/summovie_${pkgver}/bin"
+ install -d $pkgdir/usr/bin/ "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m755 * $pkgdir/usr/bin/summovie
+ install -D -m644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}