summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD29
-rwxr-xr-xsunflower.desktop12
4 files changed, 79 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..661d95b60812
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = sunflower-git
+ pkgdesc = Small and highly customizable twin-panel file manager for Linux with support for plugins
+ pkgver = 0.2.59
+ pkgrel = 0
+ url = https://github.com/MeanEYE/Sunflower
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = pygtk
+ depends = librsvg
+ optdepends = python2-notify
+ optdepends = vte
+ conflicts = sunflower
+ source = git://github.com/MeanEYE/Sunflower.git
+ source = sunflower.desktop
+
+pkgname = sunflower-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39ffb77eb3c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sunflower-git
+ pkgdesc = Small and highly customizable twin-panel file manager for Linux with support for plugins
+ pkgver = 0.2.59
+ pkgrel = 0
+ url = https://github.com/MeanEYE/Sunflower
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = pygtk
+ depends = librsvg
+ optdepends = python2-notify
+ optdepends = vte
+ conflicts = sunflower
+ source = git://github.com/MeanEYE/Sunflower.git
+ source = sunflower.desktop
+ md5sums = SKIP
+ md5sums = 9cfbe8c2075b39b9d62242ef48598105
+
+pkgname = sunflower-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..0ced98f58966
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=sunflower-git
+_gitname=Sunflower
+pkgver=0.2.59
+pkgrel=0
+pkgdesc="Small and highly customizable twin-panel file manager for Linux with support for plugins"
+arch=('any')
+url="https://github.com/MeanEYE/Sunflower"
+license=('GPL3')
+depends=('pygtk' 'librsvg')
+makedepends=('git')
+optdepends=('python2-notify' 'vte')
+conflicts=('sunflower')
+source=('git://github.com/MeanEYE/Sunflower.git'
+ 'sunflower.desktop')
+md5sums=('SKIP'
+ '9cfbe8c2075b39b9d62242ef48598105')
+pkgver() {
+cd "${srcdir}/${_gitname}"
+git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ mkdir -p $pkgdir/{opt,usr/bin}
+ cp -a $srcdir/Sunflower $pkgdir/opt/sunflower
+ echo -e '#!/bin/sh\npython2 /opt/sunflower/Sunflower.py "$@"' > $pkgdir/usr/bin/sunflower
+ chmod +x $pkgdir/usr/bin/sunflower
+ mkdir -p $pkgdir/usr/share/applications
+ cp sunflower.desktop $pkgdir/usr/share/applications/
+}
diff --git a/sunflower.desktop b/sunflower.desktop
new file mode 100755
index 000000000000..8a1e8fec5e06
--- /dev/null
+++ b/sunflower.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=sunflower.desktop
+GenericName=File Manager
+Comment=Sunflower is a small and highly customizable twin-panel file manager
+Exec=sunflower
+Icon=sunflower
+Terminal=false
+StartupNotify=true
+Type=Application
+Categories=System;Utility;Core;GTK;FileTools;FileManager;