summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2e8372c9690
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sunlesssea-hib
+ pkgdesc = Sunless Sea is a nautical roguelike in glorious 2D, presenting a non-linear, choice-heavy, personalised experience. Humblebundle version.
+ pkgver = 2016.02.22
+ pkgrel = 1
+ url = http://www.failbettergames.com/sunless/
+ arch = any
+ license = commercial
+ depends = lib32-libxcursor
+ source = hib://Sunless_Sea-StandAlone-Linux-2016-02-22.sh
+ md5sums = 91f751a8d4b6c65e50f1e8466350c5e8
+
+pkgname = sunlesssea-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d49637c96d92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: fordprefect <fordprefect@dukun.de>
+pkgname=sunlesssea-hib
+pkgver=2016.02.22
+pkgrel=1
+pkgdesc="Sunless Sea is a nautical roguelike in glorious 2D, presenting a non-linear, choice-heavy, personalised experience. Humblebundle version."
+url="http://www.failbettergames.com/sunless/"
+arch=('any')
+license=('commercial')
+depends=("lib32-libxcursor")
+source=("hib://Sunless_Sea-StandAlone-Linux-2016-02-22.sh")
+md5sums=('91f751a8d4b6c65e50f1e8466350c5e8')
+PKGEXT=.pkg.tar
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+package() {
+ # copy files
+ install -Dm755 "${srcdir}/data/x86/Sunless Sea.x86" "${pkgdir}/opt/sunlesssea/Sunless Sea.x86"
+ cp -R "${srcdir}/data/noarch/Sunless Sea_Data" "${srcdir}/data/noarch/Icon.png" "${pkgdir}/opt/sunlesssea/"
+
+ # starter script
+ mkdir -p "${pkgdir}/usr/bin"
+ cat >> "${pkgdir}/usr/bin/sunlessea" << \here
+#!/usr/bin/bash
+cd /opt/sunlesssea
+Sunless\ Sea.x86
+here
+ chmod a+x "${pkgdir}/usr/bin/sunlessea"
+}