summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c1c79f8aa07..5ee8d7d5c014 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = sunloginclient
pkgdesc = Sunlogin Remote Control is a software that supports remote control of mobile devices, Windows, Mac, Linux and other systems. It is the best choice for IT technology, game players, designers and other people with remote management needs.
pkgver = 10.0.2.24779
- pkgrel = 2
+ pkgrel = 3
url = https://sunlogin.oray.com
install = sunloginclient.INSTALL
arch = x86_64
- license = unknown
+ license = custom:sunloginclient
depends = libappindicator-gtk3
depends = webkitgtk
depends = aspell
@@ -16,7 +16,9 @@ pkgbase = sunloginclient
options = !strip
backup = etc/orayconfig.conf
source = http://download.oray.com/sunlogin/linux/SunloginClient-10.0.2.24779_amd64.deb
+ source = LICENSE::https://service.oray.com/question/1820.html
sha256sums = da2a61d106c2cecce271c89cd182b162bce34018539e1ba431580c5bbe120252
+ sha256sums = SKIP
pkgname = sunloginclient
diff --git a/PKGBUILD b/PKGBUILD
index 099404e92407..1e3cb99c7974 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
pkgname=sunloginclient
pkgver=10.0.2.24779
-pkgrel=2
+pkgrel=3
pkgdesc="Sunlogin Remote Control is a software that supports remote control of mobile devices, Windows, Mac, Linux and other systems. It is the best choice for IT technology, game players, designers and other people with remote management needs."
arch=("x86_64")
url="https://sunlogin.oray.com"
depends=("libappindicator-gtk3" "webkitgtk" 'aspell' 'hspell' 'nuspell' 'libvoikko')
-license=('unknown')
-#optdepends=('aspell' 'hspell' 'nuspell' 'libvoikko')
+license=('custom:sunloginclient')
options=("!emptydirs" "!strip")
-source=("http://download.oray.com/sunlogin/linux/SunloginClient-${pkgver}_amd64.deb")
+source=("http://download.oray.com/sunlogin/linux/SunloginClient-${pkgver}_amd64.deb"
+ 'LICENSE::https://service.oray.com/question/1820.html')
install='sunloginclient.INSTALL'
backup=("etc/orayconfig.conf")
-sha256sums=('da2a61d106c2cecce271c89cd182b162bce34018539e1ba431580c5bbe120252')
+sha256sums=('da2a61d106c2cecce271c89cd182b162bce34018539e1ba431580c5bbe120252'
+ 'SKIP')
package() {
bsdtar -xf data.tar.xz -C "${pkgdir}"
@@ -37,12 +38,14 @@ package() {
# 安装图标
install -Dm644 "${pkgdir}/opt/sunlogin/res/icon/sunlogin_client.png" "${pkgdir}/usr/share/pixmaps/sunlogin_client.png"
-
+ # 安装协议
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# 创建软链
install -dm755 "$pkgdir/usr/bin"
- ln -s "/opt/sunlogin/bin/sunloginclient" "${pkgdir}/usr/bin/sunloginclient"
+ ln -s "/opt/sunlogin/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
# ugly hack
- sed -i "s#/usr/local/sunlogin\x0#/opt/sunlogin\x0\x0\x0\x0\x0\x0\x0#g" "${pkgdir}/opt/sunlogin/bin/sunloginclient"
- sed -i "s#/usr/local/sunlogin/res/icon/%s.ico\x0#/opt/sunlogin/res/icon/%s.ico\x0\x0\x0\x0\x0\x0\x0#g" "${pkgdir}/opt/sunlogin/bin/sunloginclient"
+ sed -i "s#/usr/local/sunlogin\x0#/opt/sunlogin\x0\x0\x0\x0\x0\x0\x0#g" "${pkgdir}/opt/sunlogin/bin/${pkgname}"
+ sed -i "s#/usr/local/sunlogin/res/icon/%s.ico\x0#/opt/sunlogin/res/icon/%s.ico\x0\x0\x0\x0\x0\x0\x0#g" "${pkgdir}/opt/sunlogin/bin/${pkgname}"
}
+# vim: ts=2 sw=2 et: