summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD52
2 files changed, 21 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d6997c5deb2..fe61c340a18d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = sunshine-git
- pkgdesc = Open source implementation of NVIDIA's GameStream, as used by the NVIDIA Shield
- pkgver = 0.13.0.957.4b658cd
+ pkgdesc = Sunshine is a Gamestream host for Moonlight.
+ pkgver = 0.14.0
pkgrel = 1
- url = https://github.com/SunshineStream/sunshine
+ url = https://sunshinestream.github.io
install = sunshine.install
arch = x86_64
arch = i686
@@ -13,23 +13,19 @@ pkgbase = sunshine-git
makedepends = make
depends = boost-libs
depends = ffmpeg4.4
- depends = openssl
depends = libpulse
- depends = opus
- depends = libxtst
- depends = libx11
- depends = libxfixes
depends = libevdev
+ depends = libx11
depends = libxcb
+ depends = libxfixes
depends = libxrandr
+ depends = libxtst
+ depends = openssl
+ depends = opus
depends = udev
provides = sunshine
conflicts = sunshine
- source = sunshine-git::git+https://github.com/SunshineStream/sunshine.git
- source = systemd-user-config.patch
- source = udev.rules
+ source = sunshine-git::git+https://github.com/SunshineStream/Sunshine.git#tag=v0.14.0
sha256sums = SKIP
- sha256sums = 1642eb8672b137e94aa16e4aadde37f68bf1920dfadd1325cca480d7731f38c9
- sha256sums = 5ce01689247cb01d3f119cac32c731607d99bb875dcdd39c92b547f76d2befa0
pkgname = sunshine-git
diff --git a/PKGBUILD b/PKGBUILD
index b603e5541122..7f1c0ea13cc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,27 @@
-# Maintainer: Jacek Szafarkiewicz <szafar at linux dot pl>
-# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Edit on github: https://github.com/SunshineStream/Sunshine/tree/nightly/packaging/linux/aur/PKGBUILD
+# Reference: https://wiki.archlinux.org/title/PKGBUILD
pkgname=sunshine-git
-pkgver=0.13.0.957.4b658cd
+pkgver=0.14.0
pkgrel=1
-pkgdesc="Open source implementation of NVIDIA's GameStream, as used by the NVIDIA Shield"
-url="https://github.com/SunshineStream/sunshine"
+pkgdesc="Sunshine is a Gamestream host for Moonlight."
arch=('x86_64' 'i686')
+url=https://sunshinestream.github.io
license=('GPL3')
-depends=('boost-libs' 'ffmpeg4.4' 'openssl' 'libpulse' 'opus' 'libxtst' 'libx11' 'libxfixes' 'libevdev' 'libxcb' 'libxrandr' 'udev')
+depends=('boost-libs' 'ffmpeg4.4' 'libpulse' 'libevdev' 'libx11' 'libxcb' 'libxfixes' 'libxrandr' 'libxtst' 'openssl' 'opus' 'udev')
makedepends=('git' 'cmake' 'boost' 'make')
provides=('sunshine')
conflicts=("sunshine")
-source=("$pkgname::git+https://github.com/SunshineStream/sunshine.git"
- "systemd-user-config.patch"
- "udev.rules")
-sha256sums=('SKIP'
- '1642eb8672b137e94aa16e4aadde37f68bf1920dfadd1325cca480d7731f38c9'
- '5ce01689247cb01d3f119cac32c731607d99bb875dcdd39c92b547f76d2befa0')
+source=("$pkgname::git+https://github.com/SunshineStream/Sunshine.git#tag=v$pkgver")
+sha256sums=('SKIP')
install=sunshine.install
-_assets_path=/usr/share/sunshine
-
-pkgver() {
- cd "$pkgname"
- printf "%s.%s.%s" "$(git describe --tags $(git rev-list --tags --max-count=1) | sed 's/^v//')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
prepare() {
cd "$pkgname"
git submodule update --recursive --init
-
- patch -p1 < ../systemd-user-config.patch
}
build() {
@@ -46,8 +33,9 @@ build() {
-B build \
-Wno-dev \
-D SUNSHINE_EXECUTABLE_PATH=/usr/bin/sunshine \
- -D SUNSHINE_ASSETS_DIR="$_assets_path" \
- \
+ -D CMAKE_INSTALL_PREFIX="$pkgdir" \
+ -D SUNSHINE_ASSETS_DIR="local/sunshine/assets" \
+ -D SUNSHINE_CONFIG_DIR="local/sunshine/config" \
-D LIBAVCODEC_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
-D LIBAVCODEC_LIBRARIES=/usr/lib/ffmpeg4.4/libavcodec.so \
-D LIBAVDEVICE_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
@@ -57,27 +45,11 @@ build() {
-D LIBAVUTIL_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
-D LIBAVUTIL_LIBRARIES=/usr/lib/ffmpeg4.4/libavutil.so \
-D LIBSWSCALE_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
- -D LIBAVUTIL_LIBRARIES=/usr/lib/ffmpeg4.4/libavutil.so \
- -D LIBSWSCALE_INCLUDE_DIR=/usr/include/ffmpeg4.4 \
-D LIBSWSCALE_LIBRARIES=/usr/lib/ffmpeg4.4/libswscale.so
make -C build
}
package() {
- pushd "$pkgname/assets"
- install -Dvm644 sunshine.conf "$pkgdir/$_assets_path/sunshine.conf"
- install -Dvm644 apps_linux.json "$pkgdir/$_assets_path/apps_linux.json"
-
- find web shaders/opengl -type f -print0 | xargs -0 -I {} install -Dvm644 {} "$pkgdir/$_assets_path/{}"
- popd
-
- pushd build
- install -Dvm755 sunshine "$pkgdir/usr/bin/sunshine"
- install -Dvm644 sunshine.service "$pkgdir/usr/lib/systemd/user/sunshine.service"
- popd
-
- install -Dvm644 udev.rules "$pkgdir/usr/lib/udev/rules.d/85-sunshine.rules"
+ make install
}
-
-# vim: ts=2 sw=2 et: