summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--fix_on_vblank_args.patch26
-rw-r--r--superdux.desktop9
4 files changed, 18 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ad7a280c637..3d4181cf727f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,9 @@ pkgbase = superdux-git
conflicts = superdux
source = git+https://github.com/SnowyMouse/superdux.git
source = git+https://github.com/LIJI32/SameBoy.git
+ source = superdux.desktop
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 8c6f79c0f3dd7bcc812a3ce389eafd6d1ad7bdfec22580d4068fa69fb1ebb364
pkgname = superdux-git
diff --git a/PKGBUILD b/PKGBUILD
index 27767d22b92d..e9e605e65909 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,11 @@ arch=('x86_64')
url="https://github.com/SnowyMouse/superdux"
license=('GPL3')
source=("git+https://github.com/SnowyMouse/${pkgname%-git}.git"
- "git+https://github.com/LIJI32/SameBoy.git")
+ "git+https://github.com/LIJI32/SameBoy.git"
+ 'superdux.desktop')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '8c6f79c0f3dd7bcc812a3ce389eafd6d1ad7bdfec22580d4068fa69fb1ebb364')
provides=('superdux')
conflicts=('superdux')
@@ -34,5 +36,7 @@ build() {
}
package() {
- cmake --install build
+ cmake --install build
+ install -Dm644 "${pkgname%-git}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-git}.desktop"
+ install -Dm644 "${srcdir}/${pkgname%-git}/icon/${pkgname%-git}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-git}.png"
}
diff --git a/fix_on_vblank_args.patch b/fix_on_vblank_args.patch
deleted file mode 100644
index 7168286158a7..000000000000
--- a/fix_on_vblank_args.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/src/game_instance.cpp b/src/game_instance.cpp
-index 18a9154..1b220b5 100644
---- a/src/game_instance.cpp
-+++ b/src/game_instance.cpp
-@@ -198,7 +198,7 @@ static std::uint32_t rgb_encode(GB_gameboy_t *, uint8_t r, uint8_t g, uint8_t b)
- return 0xFF000000 | (r << 16) | (g << 8) | (b << 0);
- }
-
--void GameInstance::on_vblank(GB_gameboy_s *gameboy) noexcept {
-+void GameInstance::on_vblank(GB_gameboy_s *gameboy, GB_vblank_type_t) noexcept {
- auto *instance = resolve_instance(gameboy);
-
- // Lock this
-diff --git a/src/game_instance.hpp b/src/game_instance.hpp
-index 557c46f..2075256 100644
---- a/src/game_instance.hpp
-+++ b/src/game_instance.hpp
-@@ -831,7 +831,7 @@ private: // all private functions assume the mutex is locked by the caller
- void assign_work_buffer() noexcept;
-
- // Handle vblank
-- static void on_vblank(GB_gameboy_s *gameboy) noexcept;
-+ static void on_vblank(GB_gameboy_s *gameboy, GB_vblank_type_t) noexcept;
-
- // Log
- static void on_log(GB_gameboy_s *gameboy, const char *text, GB_log_attributes attributes) noexcept;
diff --git a/superdux.desktop b/superdux.desktop
new file mode 100644
index 000000000000..84538d8d0bb6
--- /dev/null
+++ b/superdux.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=SuperDUX
+GenericName=Gameboy Emulator
+Comment=Qt interface for SameBoy
+Icon=superdux
+TryExec=superdux
+Exec=superdux %f
+Categories=Game;Emulator;Qt;