summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD18
-rw-r--r--nova2-executable.patch23
3 files changed, 36 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe785112f459..51f8d5d7e014 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,33 @@
pkgbase = supernova
pkgdesc = Use novaclient with multiple OpenStack nova environments the easy way
- pkgver = 1.0.8
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/major/supernova
arch = any
license = Apache
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://github.com/major/supernova/archive/v1.0.8.tar.gz
+ source = https://github.com/major/supernova/archive/v2.0.0.tar.gz
source = nova2-executable.patch
- sha256sums = 5abc13e44ca1eeeb7626fe133a104fec19ec5663ea3b7077af8874cb70b7baad
- sha256sums = 688de41b2ab9f050b210b30ab24b6bf86bb40cb387eb8ef6a6816a79edb7b195
+ sha256sums = 43b27ee9ed2ca7b0b5860bf52422750e215b60cb71eca106a57b4f900faef24e
+ sha256sums = cd2d47ce9d9b949844c5e58ed7a1b32cb2367fd7c4429ec0d971fd24bd544704
pkgname = supernova
+ depends = python-click
+ depends = python-configobj
+ depends = python-keyring>=0.9.2
depends = python-novaclient
- depends = python-keyring
+ depends = python-six
conflicts = python-supernova
conflicts = python-supernova-git
conflicts = supernova-git
pkgname = supernova2
+ depends = python2-click
+ depends = python2-configobj
+ depends = python2-keyring>=0.9.2
depends = python2-novaclient
- depends = python2-keyring
+ depends = python2-six
conflicts = python2-supernova
conflicts = python2-supernova-git
conflicts = supernova2-git
diff --git a/PKGBUILD b/PKGBUILD
index 3cb08aa01802..0374f39b8898 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name="supernova"
_cmd="${_name}"
pkgname=("supernova" "supernova2")
-pkgver="1.0.8"
+pkgver="2.0.0"
pkgrel="1"
pkgdesc="Use novaclient with multiple OpenStack nova environments the easy way"
arch=("any")
@@ -13,8 +13,8 @@ license=("Apache")
makedepends=("python-setuptools" "python2-setuptools")
source=("${url}/archive/v${pkgver}.tar.gz"
"nova2-executable.patch")
-sha256sums=('5abc13e44ca1eeeb7626fe133a104fec19ec5663ea3b7077af8874cb70b7baad'
- '688de41b2ab9f050b210b30ab24b6bf86bb40cb387eb8ef6a6816a79edb7b195')
+sha256sums=('43b27ee9ed2ca7b0b5860bf52422750e215b60cb71eca106a57b4f900faef24e'
+ 'cd2d47ce9d9b949844c5e58ed7a1b32cb2367fd7c4429ec0d971fd24bd544704')
prepare() {
cp -a "${srcdir}/${_name}-${pkgver}"{,-python2}
@@ -23,7 +23,11 @@ prepare() {
package_supernova() {
conflicts=("python-supernova" "python-supernova-git" "supernova-git")
- depends=("python-novaclient" "python-keyring")
+ depends=("python-click"
+ "python-configobj"
+ "python-keyring>=0.9.2"
+ "python-novaclient"
+ "python-six")
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
install -Dm644 "contrib/${_cmd}-completion.bash" "${pkgdir}/usr/share/bash-completion/completions/${_cmd}"
@@ -31,7 +35,11 @@ package_supernova() {
package_supernova2() {
conflicts=("python2-supernova" "python2-supernova-git" "supernova2-git")
- depends=("python2-novaclient" "python2-keyring")
+ depends=("python2-click"
+ "python2-configobj"
+ "python2-keyring>=0.9.2"
+ "python2-novaclient"
+ "python2-six")
cd "${srcdir}/${_name}-${pkgver}-python2"
python2 setup.py install --root="${pkgdir}" --optimize=1
mv "${pkgdir}/usr/bin/${_cmd}" "${pkgdir}/usr/bin/${_cmd}2"
diff --git a/nova2-executable.patch b/nova2-executable.patch
index d6626a3a1d1c..cb643c7ccb3f 100644
--- a/nova2-executable.patch
+++ b/nova2-executable.patch
@@ -1,13 +1,12 @@
-diff --git a/supernova/executable.py b/supernova/executable.py
-index d585d81..35712e1 100644
---- a/supernova/executable.py
-+++ b/supernova/executable.py
-@@ -64,7 +64,7 @@ def run_supernova():
- config.run_config()
+diff -Naurp a/supernova/executable.py b/supernova/executable.py
+--- a/supernova/executable.py 2015-07-18 00:22:07.000000000 -0500
++++ b/supernova/executable.py 2015-07-18 21:58:23.018328979 -0500
+@@ -57,7 +57,7 @@ def print_env_list(ctx, param, value):
- parser = argparse.ArgumentParser()
-- parser.add_argument('-x', '--executable', default='nova',
-+ parser.add_argument('-x', '--executable', default='nova2',
- help='command to run instead of nova')
- parser.add_argument('--version', action=_ShowVersion,
- help='display supernova version')
+
+ @click.command()
+-@click.option('--executable', '-x', default='nova',
++@click.option('--executable', '-x', default='nova2',
+ help='Command to run', show_default=True)
+ @click.option('--debug', '-d', default=False, is_flag=True,
+ help="Enable debugging", show_default=True)