summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001_revert_pillow_7.0_requirement.patch33
-rw-r--r--PKGBUILD17
3 files changed, 6 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2bf9b841a85..dcf9d85fb316 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = superpaper
pkgdesc = Cross-platform multi monitor wallpaper manager
pkgver = 2.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hhannine/Superpaper
arch = any
license = MIT
makedepends = python-distutils-extra
- depends = python-pillow
+ depends = python-pillow>=7.0
depends = python-screeninfo>=0.6.1
depends = python-wxpython
depends = python-system_hotkey>=1.0.2+10+9541587
depends = python-xpybutil
depends = python-numpy
source = superpaper-2.0.2.tar.gz::https://github.com/hhannine/Superpaper/archive/v2.0.2.tar.gz
- source = 0001_revert_pillow_7.0_requirement.patch
sha256sums = 58b5c7f79d772142c819b00f4925193bc135fa29312d933b3a7cd8adcad9f56c
- sha256sums = 0e00a061c96564310c42f8a18b8a2f67ac44a31544f1f48d496445f78b6f3530
pkgname = superpaper
diff --git a/0001_revert_pillow_7.0_requirement.patch b/0001_revert_pillow_7.0_requirement.patch
deleted file mode 100644
index 5893fad6f5bb..000000000000
--- a/0001_revert_pillow_7.0_requirement.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naur ./superpaper-2.0.2.orig/setup.py ./superpaper-2.0.2/setup.py
---- ./superpaper-2.0.2.orig/setup.py 2020-05-09 20:16:03.999703051 -0400
-+++ ./superpaper-2.0.2/setup.py 2020-05-09 20:18:31.242189059 -0400
-@@ -58,7 +58,7 @@
-
- # python_requires="~=3.5",
- install_requires=[
-- "Pillow>=7.0.0",
-+ "Pillow>=6.0.0",
- "screeninfo>=0.6.1",
- "numpy>=1.18.0",
- "system_hotkey>=1.0.3",
-diff -Naur ./superpaper-2.0.2.orig/superpaper/wallpaper_processing.py ./superpaper-2.0.2/superpaper/wallpaper_processing.py
---- ./superpaper-2.0.2.orig/superpaper/wallpaper_processing.py 2020-05-09 20:16:03.996369661 -0400
-+++ ./superpaper-2.0.2/superpaper/wallpaper_processing.py 2020-05-09 20:16:46.463443631 -0400
-@@ -927,7 +927,7 @@
- new_size = (
- round(resize_multiplier * image_size[0]),
- round(resize_multiplier * image_size[1]))
-- img = img.resize(new_size, resample=quality, reducing_gap=reducing_gap)
-+ img = img.resize(new_size, resample=quality) #, reducing_gap=reducing_gap)
- # crop vertically to target height
- extra_height = new_size[1] - res[1]
- if extra_height < 0:
-@@ -958,7 +958,7 @@
- new_size = (
- round(resize_multiplier * image_size[0]),
- round(resize_multiplier * image_size[1]))
-- img = img.resize(new_size, resample=quality, reducing_gap=reducing_gap)
-+ img = img.resize(new_size, resample=quality) #, reducing_gap=reducing_gap)
- # crop horizontally to target width
- extra_width = new_size[0] - res[0]
- if extra_width < 0:
diff --git a/PKGBUILD b/PKGBUILD
index 8035ec97776c..fcd90d0886d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,17 @@
pkgname=superpaper
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Cross-platform multi monitor wallpaper manager"
arch=('any')
url="https://github.com/hhannine/Superpaper"
license=('MIT')
-depends=('python-pillow' 'python-screeninfo>=0.6.1' 'python-wxpython'
+depends=('python-pillow>=7.0' 'python-screeninfo>=0.6.1' 'python-wxpython'
'python-system_hotkey>=1.0.2+10+9541587' 'python-xpybutil' 'python-numpy')
makedepends=('python-distutils-extra')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hhannine/${pkgname^}/archive/v${pkgver}.tar.gz"
- '0001_revert_pillow_7.0_requirement.patch')
-sha256sums=('58b5c7f79d772142c819b00f4925193bc135fa29312d933b3a7cd8adcad9f56c'
- '0e00a061c96564310c42f8a18b8a2f67ac44a31544f1f48d496445f78b6f3530')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hhannine/${pkgname^}/archive/v${pkgver}.tar.gz")
+sha256sums=('58b5c7f79d772142c819b00f4925193bc135fa29312d933b3a7cd8adcad9f56c')
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- # Revert image optimizations which bumped the Pillow dep to 7.0+
- # until Arch updates the python-pillow package.
- patch -Np2 -r- -i ../0001_revert_pillow_7.0_requirement.patch
-}
-
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root "${pkgdir}" --optimize=1