summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Replace-deprecated-Boost-header-in-admesh.patch63
-rw-r--r--PKGBUILD17
-rw-r--r--start-superslicer.sh13
4 files changed, 24 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca55256025f0..d67aaf8b7fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = superslicer
pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
- pkgver = 2.2.54.2
- pkgrel = 4
+ pkgver = 2.3.56.4
+ pkgrel = 1
epoch = 1
url = https://github.com/supermerill/SuperSlicer
arch = x86_64
@@ -20,17 +20,15 @@ pkgbase = superslicer
depends = boost>=1.73.0
depends = qhull>=2020.2-4
replaces = slic3r++
- source = https://github.com/supermerill//SuperSlicer/archive/2.2.54.2.tar.gz
+ source = https://github.com/supermerill//SuperSlicer/archive/2.3.56.4.tar.gz
source = superslicer.desktop
source = start-superslicer.sh
source = 0001-wxgtk3-is-broken-on-wayland.patch
- source = 0001-Replace-deprecated-Boost-header-in-admesh.patch
source = https://raw.githubusercontent.com/archlinux/svntogit-community/1dea61c0b581ff5001d073689f68b0323740be93/trunk/prusa-slicer-openexr3.patch
- sha512sums = 3e28d28f463be49217d4aa19691bd190d644f86474786db69ec82d58090d2231a6c0add66eec59ac9f8c2169bfcd730a0c9deafd9df48182e92194bf6d2f39b6
+ sha512sums = 88c73ebe7b2991170f4fe3fa7f2057750072f315a80e550c811ed4bc681dc2a86740ea82c402a114f50124a641c7c3a43fbb9250a7091fdea53d7a246a82bf82
sha512sums = 8f75de56ba3e29b9c650d2946bd11afcf406a7fd42d2620ec44e4e76f6b64626de720190ce0f8be29ba7c48f714bfa0a71c45f868bdce7bc1ac7dbbc0e9e7583
- sha512sums = abfbd056be518b1b733cddef6c430cc3c4199d5df13067574dd3269cf35b798e11b43f55f1dfb57d6d8ee1da06882825fef0f7a170a9b069b95e9aea1ec8f31d
+ sha512sums = 17c003a24e2308de5d35accced010ff6f531eeedba28f5cbf492f5792ff7c0bec7c3c02f13d91a8517ea8fed189cdbf167a8c921f4d99d294fb3a205fa6ce308
sha512sums = acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5
- sha512sums = 9a860dbac69ca7a195ef43cb2b80a8b5cf2c34bddb91867aa8ba16bbb754ab68c4baf57fa7e2562f96facc435c64ed8445505edb152382dbc5106a509136a2c8
sha512sums = c33c2414746bc9d7dceb5af59ecb4aed2189211fc3c8b144d712a39d3677ba4d366eb9b4dd05fbc3811954d69cd1273d714dc4536489fe153ac1aee2919e5c98
pkgname = superslicer
diff --git a/0001-Replace-deprecated-Boost-header-in-admesh.patch b/0001-Replace-deprecated-Boost-header-in-admesh.patch
deleted file mode 100644
index bea239bfadcb..000000000000
--- a/0001-Replace-deprecated-Boost-header-in-admesh.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 3a194f91871684b5fc8c6c78300b87e0ee1cb610 Mon Sep 17 00:00:00 2001
-From: Megidd <megiddgit@gmail.com>
-Date: Mon, 21 Sep 2020 18:00:52 +0330
-Subject: [PATCH] Replace deprecated Boost header in "admesh"
-
----
- src/admesh/stlinit.cpp | 14 +++++++-------
- 1 file changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/admesh/stlinit.cpp b/src/admesh/stlinit.cpp
-index 390fe56a4..6aa2c4417 100644
---- a/src/admesh/stlinit.cpp
-+++ b/src/admesh/stlinit.cpp
-@@ -28,7 +28,7 @@
-
- #include <boost/log/trivial.hpp>
- #include <boost/nowide/cstdio.hpp>
--#include <boost/detail/endian.hpp>
-+#include <boost/predef/other/endian.h>
-
- #include "stl.h"
-
-@@ -36,9 +36,9 @@
- #error "SEEK_SET not defined"
- #endif
-
--#ifndef BOOST_LITTLE_ENDIAN
-+#if BOOST_ENDIAN_BIG_BYTE
- extern void stl_internal_reverse_quads(char *buf, size_t cnt);
--#endif /* BOOST_LITTLE_ENDIAN */
-+#endif /* BOOST_ENDIAN_BIG_BYTE */
-
- static FILE* stl_open_count_facets(stl_file *stl, const char *file)
- {
-@@ -89,10 +89,10 @@ static FILE* stl_open_count_facets(stl_file *stl, const char *file)
- // Read the int following the header. This should contain # of facets.
- uint32_t header_num_facets;
- bool header_num_faces_read = fread(&header_num_facets, sizeof(uint32_t), 1, fp) != 0;
--#ifndef BOOST_LITTLE_ENDIAN
-+#if BOOST_ENDIAN_BIG_BYTE
- // Convert from little endian to big endian.
- stl_internal_reverse_quads((char*)&header_num_facets, 4);
--#endif /* BOOST_LITTLE_ENDIAN */
-+#endif /* BOOST_ENDIAN_BIG_BYTE */
- if (! header_num_faces_read || num_facets != header_num_facets)
- BOOST_LOG_TRIVIAL(info) << "stl_open_count_facets: Warning: File size doesn't match number of facets in the header: " << file;
- }
-@@ -158,10 +158,10 @@ static bool stl_read(stl_file *stl, FILE *fp, int first_facet, bool first)
- // Read a single facet from a binary .STL file. We assume little-endian architecture!
- if (fread(&facet, 1, SIZEOF_STL_FACET, fp) != SIZEOF_STL_FACET)
- return false;
--#ifndef BOOST_LITTLE_ENDIAN
-+#if BOOST_ENDIAN_BIG_BYTE
- // Convert the loaded little endian data to big endian.
- stl_internal_reverse_quads((char*)&facet, 48);
--#endif /* BOOST_LITTLE_ENDIAN */
-+#endif /* BOOST_ENDIAN_BIG_BYTE */
- } else {
- // Read a single facet from an ASCII .STL file
- // skip solid/endsolid
---
-2.29.2
-
diff --git a/PKGBUILD b/PKGBUILD
index bf68280014c4..3e7494665fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Lukas1818 aur at lukas1818 dot de
pkgname=superslicer
-pkgver=2.2.54.2
+pkgver=2.3.56.4
_pkgtag=$pkgver
-pkgrel=4
+pkgrel=1
epoch=1
pkgdesc="G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)"
arch=('x86_64')
@@ -16,13 +16,11 @@ source=("https://github.com/supermerill//SuperSlicer/archive/$_pkgtag.tar.gz"
"superslicer.desktop"
"start-superslicer.sh"
"0001-wxgtk3-is-broken-on-wayland.patch"
- "0001-Replace-deprecated-Boost-header-in-admesh.patch"
"https://raw.githubusercontent.com/archlinux/svntogit-community/1dea61c0b581ff5001d073689f68b0323740be93/trunk/prusa-slicer-openexr3.patch")
-sha512sums=('3e28d28f463be49217d4aa19691bd190d644f86474786db69ec82d58090d2231a6c0add66eec59ac9f8c2169bfcd730a0c9deafd9df48182e92194bf6d2f39b6'
+sha512sums=('88c73ebe7b2991170f4fe3fa7f2057750072f315a80e550c811ed4bc681dc2a86740ea82c402a114f50124a641c7c3a43fbb9250a7091fdea53d7a246a82bf82'
'8f75de56ba3e29b9c650d2946bd11afcf406a7fd42d2620ec44e4e76f6b64626de720190ce0f8be29ba7c48f714bfa0a71c45f868bdce7bc1ac7dbbc0e9e7583'
- 'abfbd056be518b1b733cddef6c430cc3c4199d5df13067574dd3269cf35b798e11b43f55f1dfb57d6d8ee1da06882825fef0f7a170a9b069b95e9aea1ec8f31d'
+ '17c003a24e2308de5d35accced010ff6f531eeedba28f5cbf492f5792ff7c0bec7c3c02f13d91a8517ea8fed189cdbf167a8c921f4d99d294fb3a205fa6ce308'
'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5'
- '9a860dbac69ca7a195ef43cb2b80a8b5cf2c34bddb91867aa8ba16bbb754ab68c4baf57fa7e2562f96facc435c64ed8445505edb152382dbc5106a509136a2c8'
'c33c2414746bc9d7dceb5af59ecb4aed2189211fc3c8b144d712a39d3677ba4d366eb9b4dd05fbc3811954d69cd1273d714dc4536489fe153ac1aee2919e5c98')
prepare()
@@ -34,11 +32,8 @@ prepare()
# apply patches
patch --forward --strip=1 --input="$srcdir/0001-wxgtk3-is-broken-on-wayland.patch"
- patch --forward --strip=1 --input="$srcdir/0001-Replace-deprecated-Boost-header-in-admesh.patch"
- if pacman -qQi imath &> /dev/null # not all distros has already upgrade to openEXR 3
- then
- patch -p1 < "$srcdir/prusa-slicer-openexr3.patch" # Fix build with openEXR 3
- fi
+ patch -p1 < "$srcdir/prusa-slicer-openexr3.patch" # Fix build with openEXR 3
+
}
build()
diff --git a/start-superslicer.sh b/start-superslicer.sh
index 9c38b060309b..4d8694a73446 100644
--- a/start-superslicer.sh
+++ b/start-superslicer.sh
@@ -1,2 +1,15 @@
#!/bin/bash
+
+import_settings()
+{
+ if [ -d "$1" ] && [ ! -d "$HOME/.config/SuperSlicer" ]
+ then
+ echo "import data from $1 to the new data folder ~/.config/SuperSlicer"
+ cp -r "$HOME/.SuperSlicer" "$HOME/.config/SuperSlicer"
+ fi
+}
+
+import_settings "$HOME/.SuperSlicer"
+import_settings "$HOME/.config/SuperSlicer-alpha"
+
LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/wxgtk-dev/lib" /usr/share/SuperSlicer/superslicer "$@"