summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--0001-PrintObject-no-return.patch12
-rw-r--r--0001-wxgtk3-is-broken-on-wayland.patch (renamed from 0002-wxgtk3-is-broken-on-wayland.patch)0
-rw-r--r--PKGBUILD22
4 files changed, 15 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ae8678bbf97..a60d4e8a72a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = slic3r++
pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
- pkgver = 2.2.47.1
- pkgrel = 2
+ pkgver = 2.2.49.0
+ pkgrel = 1
url = https://github.com/supermerill/Slic3r
arch = x86_64
license = AGPL3
@@ -18,13 +18,11 @@ pkgbase = slic3r++
depends = nlopt
depends = qhull
depends = wxgtk3
- source = https://github.com/supermerill/Slic3r/archive/2.2.47.1.tar.gz
+ source = https://github.com/supermerill/Slic3r/archive/1.39.0.tar.gz
source = slic3r++.desktop
- source = 0001-PrintObject-no-return.patch
- source = 0002-wxgtk3-is-broken-on-wayland.patch
- sha512sums = 47a36014f3b34b68ef190bf1e904b5dcc69d2a7e695d732bd2a0583fd30ea02693a6298db96f2a4eead6f2c51b076b03faf56963e8fa3b6d9c3c647342adb237
+ source = 0001-wxgtk3-is-broken-on-wayland.patch
+ sha512sums = 5ed6416529551d63932fadab702983a85870c253a598452b45c30a7d97132a5740b826ca8fbf61e747727b2143a1b507207f478309e3887682151106541bda25
sha512sums = 2f9e364724e28e26c328b83cbf76c6d05544469c3ae14324ae11a1c97fc11878d1f892674ddc6440d14d8bfbca80ba8fc0dcbaa7cf3b7420e91962ee9582b8a2
- sha512sums = cbeae074b5c395e34615aa19a35cf7a83ea479a35ea1e8dadc435650eeb8dc8933c01ab94e1b9f6cbebde49017f9d3ef21c2b16b0d31057e4965fdb5fd6dd44d
sha512sums = acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5
pkgname = slic3r++
diff --git a/0001-PrintObject-no-return.patch b/0001-PrintObject-no-return.patch
deleted file mode 100644
index f1fdbf566f6d..000000000000
--- a/0001-PrintObject-no-return.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/libslic3r/PrintObject.cpp b/src/libslic3r/PrintObject.cpp
-index d7d4f0799..94cf4dbed 100644
---- a/src/libslic3r/PrintObject.cpp
-+++ b/src/libslic3r/PrintObject.cpp
-@@ -2491,6 +2491,7 @@ ExPolygons PrintObject::_smooth_curves(const ExPolygons & input, const PrintRegi
- }
- return new_polys;
- }
-+ return ExPolygons();
- }
-
- // To be used only if there are no layer span specific configurations applied, which would lead to z ranges being generated for this region.
diff --git a/0002-wxgtk3-is-broken-on-wayland.patch b/0001-wxgtk3-is-broken-on-wayland.patch
index b0371b4159a6..b0371b4159a6 100644
--- a/0002-wxgtk3-is-broken-on-wayland.patch
+++ b/0001-wxgtk3-is-broken-on-wayland.patch
diff --git a/PKGBUILD b/PKGBUILD
index 035f18c48a37..19209be3a800 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,36 @@
# Maintainer: Dominic Meiser git at msrd0 dot de
pkgname=slic3r++
-pkgver=2.2.47.1
-pkgrel=2
+pkgver=2.2.49.0
+_pkgtag=1.39.0
+pkgrel=1
pkgdesc="G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)"
arch=('x86_64')
url="https://github.com/supermerill/Slic3r"
license=('AGPL3')
depends=('boost-libs' 'glew' 'intel-tbb' 'nlopt' 'qhull' 'wxgtk3')
makedepends=('boost' 'cereal' 'cmake' 'eigen' 'libigl' 'openvdb' 'wxgtk2') # cmake doesn't detect wx if not both gtk2 and gtk3 are installed
-source=("https://github.com/supermerill/Slic3r/archive/$pkgver.tar.gz"
+source=("https://github.com/supermerill/Slic3r/archive/$_pkgtag.tar.gz"
"slic3r++.desktop"
- "0001-PrintObject-no-return.patch"
- "0002-wxgtk3-is-broken-on-wayland.patch")
-sha512sums=('47a36014f3b34b68ef190bf1e904b5dcc69d2a7e695d732bd2a0583fd30ea02693a6298db96f2a4eead6f2c51b076b03faf56963e8fa3b6d9c3c647342adb237'
+ "0001-wxgtk3-is-broken-on-wayland.patch")
+sha512sums=('5ed6416529551d63932fadab702983a85870c253a598452b45c30a7d97132a5740b826ca8fbf61e747727b2143a1b507207f478309e3887682151106541bda25'
'2f9e364724e28e26c328b83cbf76c6d05544469c3ae14324ae11a1c97fc11878d1f892674ddc6440d14d8bfbca80ba8fc0dcbaa7cf3b7420e91962ee9582b8a2'
- 'cbeae074b5c395e34615aa19a35cf7a83ea479a35ea1e8dadc435650eeb8dc8933c01ab94e1b9f6cbebde49017f9d3ef21c2b16b0d31057e4965fdb5fd6dd44d'
'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5')
prepare()
{
- cd "$srcdir/Slic3r-$pkgver"
+ cd "$srcdir/Slic3r-$_pkgtag"
# disabling tests is not enough, we need to remove them explicitly
sed -i 's,add_subdirectory(test),,g' src/CMakeLists.txt
# apply patches
- patch --forward --strip=1 --input="$srcdir/0001-PrintObject-no-return.patch"
- patch --forward --strip=1 --input="$srcdir/0002-wxgtk3-is-broken-on-wayland.patch"
+ patch --forward --strip=1 --input="$srcdir/0001-wxgtk3-is-broken-on-wayland.patch"
}
build()
{
- cd "$srcdir/Slic3r-$pkgver"
+ cd "$srcdir/Slic3r-$_pkgtag"
mkdir -p build
cd build
@@ -50,7 +48,7 @@ build()
package()
{
- cd "$srcdir/Slic3r-$pkgver/build"
+ cd "$srcdir/Slic3r-$_pkgtag/build"
make DESTDIR="$pkgdir" install
test ! -h "$pkgdir/usr/share/slic3r++/resources" || rm "$pkgdir/usr/share/slic3r++/resources"