summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 6 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c9ac6dc3050..da8af1db8c40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = supertux-git
pkgdesc = A classic 2D jump'n run sidescroller game in a style similar to the original SuperMario game
- pkgver = v0.5.1.r423.gcd4bdbf70
+ pkgver = v0.5.1.r457.g7430e289e
pkgrel = 1
epoch = 1
url = http://supertux.lethargik.org/
@@ -20,20 +20,6 @@ pkgbase = supertux-git
provides = supertux
conflicts = supertux
source = git+https://github.com/SuperTux/supertux.git
- source = git+https://github.com/SuperTux/data.git
- source = git+https://github.com/google/googletest.git
- source = git+https://github.com/SuperTux/physfs.git
- source = git+https://github.com/SuperTux/sexp-cpp.git
- source = git+https://github.com/albertodemichelis/squirrel.git
- source = git+https://github.com/SuperTux/tinygettext.git
- source = git+https://github.com/SuperTux/translations.git
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
sha512sums = SKIP
pkgname = supertux-git
diff --git a/PKGBUILD b/PKGBUILD
index 3282ee3173b8..12921f7ae7ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=supertux-git
_pkgname=supertux
-pkgver=v0.5.1.r423.gcd4bdbf70
+pkgver=v0.5.1.r457.g7430e289e
pkgrel=1
epoch=1
pkgdesc="A classic 2D jump'n run sidescroller game in a style similar to the original SuperMario game"
@@ -16,24 +16,9 @@ depends=('sdl2_image' 'openal' 'libvorbis' 'glew' 'boost-libs' 'curl')
makedepends=('git' 'cmake' 'physfs' 'boost')
conflicts=(supertux)
provides=(supertux)
-source=('git+https://github.com/SuperTux/supertux.git'
- # submodules
- 'git+https://github.com/SuperTux/data.git'
- 'git+https://github.com/google/googletest.git'
- 'git+https://github.com/SuperTux/physfs.git'
- 'git+https://github.com/SuperTux/sexp-cpp.git'
- 'git+https://github.com/albertodemichelis/squirrel.git'
- 'git+https://github.com/SuperTux/tinygettext.git'
- 'git+https://github.com/SuperTux/translations.git')
-sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
-
+source=('git+https://github.com/SuperTux/supertux.git')
+sha512sums=('SKIP')
+
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -42,15 +27,7 @@ pkgver() {
prepare() {
cd "$_pkgname"
- git submodule init
- git config submodule.data.url "${srcdir}"/data
- git config submodule.external/googletest.url "${srcdir}"/googletest
- git config submodule.external/physfs.url "${srcdir}"/physfs
- git config submodule.external/sexp-cpp.url "${srcdir}"/sexp-cpp
- git config submodule.external/squirrel.url "${srcdir}"/squirrel
- git config submodule.external/tinygettext.url "${srcdir}"/tinygettext
- git config submodule.translations.url "${srcdir}"/translations
- git submodule update
+ git submodule update --init --recursive
sed -i '/curl\/types.h/d' src/addon/addon_manager.cpp
sed -i '1i#include <cstddef>' src/supertux/screen_manager.hpp