summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4a23a0e46f1..816d0a04b034 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = surface-control-bin
pkgdesc = Control various aspects of Microsoft Surface devices from the Command-Line
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/linux-surface/surface-control
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = surface-control-bin
depends = gcc-libs
provides = surface-control
conflicts = surface-control
- source = https://github.com/linux-surface/surface-control/releases/download/v0.3.0-1/surface-control-0.3.0.1-x86_64.bin.tar.xz
- sha256sums = 21cf5399e3e6efad884a10a3fcd449f1e11d0c742aae8e3c019a15d844a3e263
+ source = https://github.com/linux-surface/surface-control/releases/download/v0.3.1-1/surface-control-0.3.1.1-x86_64.bin.tar.xz
+ sha256sums = 193f5925d47bd485478dd6516b39d7cc2c8e7e865fdf137f3b58491d38a16e84
pkgname = surface-control-bin
diff --git a/PKGBUILD b/PKGBUILD
index 509efb8b7664..652bee85a966 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname='surface-control'
pkgname="${_pkgname}-bin"
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
_pkgrel=1
pkgdesc='Control various aspects of Microsoft Surface devices from the Command-Line'
@@ -18,12 +18,16 @@ source=(
"https://github.com/linux-surface/surface-control/releases/download/v${pkgver}-${_pkgrel}/surface-control-${pkgver}.${_pkgrel}-${CARCH}.bin.tar.xz"
)
-sha256sums=('21cf5399e3e6efad884a10a3fcd449f1e11d0c742aae8e3c019a15d844a3e263')
+sha256sums=('193f5925d47bd485478dd6516b39d7cc2c8e7e865fdf137f3b58491d38a16e84')
package() {
install -D -m755 "bin/surface" "$pkgdir/usr/bin/surface"
+ # copy system files
+ install -D -m644 "usr/lib/sysusers.d/surface-control.conf" "${pkgdir}/usr/lib/sysusers.d/surface-control.conf"
+ install -D -m644 "usr/lib/udev/rules.d/40-surface-control.rules" "${pkgdir}/usr/lib/udev/rules.d/40-surface-control.rules"
+
# completion files
install -D -m644 "shell-completions/surface.bash" "$pkgdir/usr/share/bash-completion/completions/surface"
install -D -m644 "shell-completions/surface.zsh" "$pkgdir/usr/share/zsh/site-functions/_surface"