summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 37 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 172d0eee842f..68c926e5c332 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = suscan-git
pkgdesc = SUScan is a graphical signal analysis tool
- pkgver = 0.1
+ pkgver = r1149.390fb68
pkgrel = 1
url = https://github.com/BatchDrake/suscan
arch = any
license = GPL
+ makedepends = git
+ makedepends = cmake
depends = soapysdr
- depends = sigutils-git
+ depends = sigutils
+ depends = fftw
+ depends = libsndfile
+ depends = libxml2
+ optdepends = libvolk
provides = suscan
conflicts = suscan
- source = suscan::git+https://github.com/BatchDrake/suscan.git
+ source = suscan-git::git+https://github.com/BatchDrake/suscan.git#branch=develop
md5sums = SKIP
pkgname = suscan-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 24bc5228297d..612bf38eea2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,45 @@
-# Maintainer: Julio Diez <juliosddr@gmail.com>
-_pkgname=suscan
-pkgname="${_pkgname}-git"
-pkgver=0.1
+# Maintainer: Antonio Vázquez Blanco <antoniovazquezblanco@gmail.com>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Julio Diez <juliosddr@gmail.com>
+
+pkgname=suscan-git
+pkgver=r1149.390fb68
pkgrel=1
pkgdesc="SUScan is a graphical signal analysis tool"
arch=("any")
url="https://github.com/BatchDrake/suscan"
license=("GPL")
-depends=("soapysdr" "sigutils-git")
+depends=("soapysdr" "sigutils" "fftw" "libsndfile" "libxml2")
+makedepends=("git" "cmake")
+optdepends=("libvolk")
provides=("suscan")
conflicts=("suscan")
-source=(suscan::git+https://github.com/BatchDrake/suscan.git)
-md5sums=("SKIP")
+source=("$pkgname::git+https://github.com/BatchDrake/suscan.git#branch=develop")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git -c protocol.file.allow=always submodule update
+}
build() {
- cd "$_pkgname"
-
- autoreconf -fvi
+ cd "$pkgname"
+
+ mkdir build
+ cd build
- ./configure --prefix=/usr
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_SKIP_RPATH=ON -DCMAKE_SKIP_INSTALL_RPATH=ON ..
make
}
package() {
- cd "$_pkgname"
+ cd "$pkgname/build"
make DESTDIR="$pkgdir/" install
}