summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD39
-rw-r--r--swamp-wine.install3
-rw-r--r--swamp.desktop10
-rw-r--r--swamp.sh20
5 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56b7580b8a88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = swamp-wine
+ pkgdesc = First-person Audio Shooter
+ pkgver = 3.8C
+ pkgrel = 1
+ url = https://kaldobsky.com/audiogames
+ install = swamp-wine.install
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
+ license = custom
+ makedepends = unzip
+ depends = wine
+ depends = winetricks
+ depends = wine_gecko
+ depends = wine-mono
+ depends = sdl2
+ depends = ncurses
+ depends = mpg123
+ depends = libpulse
+ depends = libpng
+ depends = libjpeg-turbo
+ depends = gnutls
+ depends = alsa-plugins
+ depends = alsa-lib
+ depends = mesa
+ depends = openal
+ depends = lib32-sdl2
+ depends = lib32-ncurses
+ depends = lib32-mpg123
+ depends = lib32-libpulse
+ depends = lib32-libpng
+ depends = lib32-libjpeg-turbo
+ depends = lib32-gnutls
+ depends = lib32-alsa-plugins
+ depends = lib32-alsa-lib
+ depends = lib32-mesa
+ depends = lib32-openal
+ noextract = Swamp.zip
+ source = https://kaldobsky.com/audiogames/Swamp.zip
+ source = swamp.sh
+ source = swamp.desktop
+ md5sums = 57b40c8eb603ce0d4afdcdb0ab0d5df6
+ md5sums = da8f92a4401b59490f4f40cc306e9de8
+ md5sums = 5f057a09fe8f0d8e21e7636a3a33a184
+
+pkgname = swamp-wine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..606a0a8d5ffd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Michael Taboada <michael@2mb.solutions.
+# Maintainer: Storm Dragon <storm_dragon@linux-a11y.org>
+pkgname=swamp-wine
+pkgver=3.8C
+pkgrel=1
+pkgdesc="First-person Audio Shooter"
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
+url="https://kaldobsky.com/audiogames"
+license=('custom')
+_depends_x86_64=(lib32-sdl2 lib32-ncurses lib32-mpg123 lib32-libpulse lib32-libpng lib32-libjpeg-turbo lib32-gnutls lib32-alsa-plugins lib32-alsa-lib lib32-mesa lib32-openal)
+depends=(wine winetricks wine_gecko wine-mono sdl2 ncurses mpg123 libpulse libpng libjpeg-turbo gnutls alsa-plugins alsa-lib mesa openal)
+if [ "$CARCH" == "x86_64" ] ;then
+ depends+=(${_depends_x86_64[@]})
+fi
+makedepends=(unzip)
+install="swamp-wine.install"
+source=('https://kaldobsky.com/audiogames/Swamp.zip'
+ 'swamp.sh'
+ 'swamp.desktop')
+md5sums=('57b40c8eb603ce0d4afdcdb0ab0d5df6'
+ 'da8f92a4401b59490f4f40cc306e9de8'
+ '5f057a09fe8f0d8e21e7636a3a33a184')
+noextract=('Swamp.zip')
+
+prepare() {
+ cd "$srcdir"
+ mkdir swamp
+ unzip -q -d swamp Swamp.zip
+}
+
+package() {
+ cd "$srcdir"
+ install -dm755 "$pkgdir"/opt/swamp
+ cp -R swamp/* "$pkgdir"/opt/swamp
+ install -dm755 "$pkgdir"/usr/bin
+ install -m755 swamp.sh "$pkgdir"/usr/bin/swamp
+ install -dm755 "$pkgdir"/usr/share/applications/
+ cp swamp.desktop "$pkgdir"/usr/share/applications
+}
diff --git a/swamp-wine.install b/swamp-wine.install
new file mode 100644
index 000000000000..17ca9551e2eb
--- /dev/null
+++ b/swamp-wine.install
@@ -0,0 +1,3 @@
+post_install() {
+echo "Note: This game is known to not work well on certain window managers -- ratpoison inparticular. If you experience issues, try switching window managers or using a full fledged desktop environment such as mate or gnome."
+}
diff --git a/swamp.desktop b/swamp.desktop
new file mode 100644
index 000000000000..0e9bdfcaa631
--- /dev/null
+++ b/swamp.desktop
@@ -0,0 +1,10 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Name=Swamp
+Comment=First person audio shooter
+Exec=swamp
+Terminal=false
+Icon=swamp
+Type=Application
+Categories=Wine;Game;Games;
diff --git a/swamp.sh b/swamp.sh
new file mode 100644
index 000000000000..2a92b3c6182a
--- /dev/null
+++ b/swamp.sh
@@ -0,0 +1,20 @@
+#! /bin/bash
+
+if [ ! -d "$HOME/.local/wine/swamp" ] ; then
+ mkdir -p "$HOME/.local/wine/swamp"
+ if [ ! -z "$DISPLAY" ] ;then
+ echo "Installing a new wineprefix for swamp. This may take a while."
+ else
+ echo "You don't seem to have an X server running, or your DISPLAY variable is not exported. Please fix this before continuing since it is needed for the installation."
+ exit 1
+ fi
+ DISPLAY="" WINEPREFIX="$HOME/.local/wine/swamp" WINEARCH=win32 wineboot -u # Clearing the display temporarily is required to work around wine complaining about mono which we install later
+ WINEPREFIX="$HOME/.local/wine/swamp" wine msiexec /i z:/usr/share/wine/mono/$(ls -1 /usr/share/wine/mono/) /silent
+ WINEPREFIX="$HOME/.local/wine/swamp" wine msiexec /i z:$(ls -1 /usr/share/wine/gecko/*x86.msi) /silent
+ WINEPREFIX="$HOME/.local/wine/swamp" winetricks -q vb6run dx8vb quartz speechsdk corefonts
+ cp -R /opt/swamp "$HOME/.local/wine/swamp/drive_c/users/$USER/Downloads"
+ WINEPREFIX="$HOME/.local/wine/swamp" wine cmd.exe /c 'cd /d c:\users\'$USER'\Downloads\swamp && Windows32bit.bat'
+ echo "Installation of the wineprefix has been completed. The game will now launch."
+fi
+WINEPREFIX="$HOME/.local/wine/swamp" wine 'c:\users\'$USER'\Downloads\swamp\Swamp.exe'
+exit $?