summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore6
-rw-r--r--50-systemd-user.conf7
-rw-r--r--PKGBUILD81
4 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1191937b320
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = sway-inhibit-fullscreen-git
+ pkgdesc = Sway with inhibit_fullscreen command
+ pkgver = r6655.7036c198
+ pkgrel = 1
+ url = https://swaywm.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = scdoc
+ makedepends = wayland-protocols
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = json-c
+ depends = pango
+ depends = polkit
+ depends = pcre
+ depends = swaybg
+ depends = ttf-font
+ depends = wlroots
+ depends = xorg-server-xwayland
+ optdepends = alacritty: Terminal emulator used by the default config
+ optdepends = dmenu: Application launcher
+ optdepends = grim: Screenshot utility
+ optdepends = i3status: Status line
+ optdepends = mako: Lightweight notification daemon
+ optdepends = slurp: Select a region
+ optdepends = swayidle: Idle management daemon
+ optdepends = swaylock: Screen locker
+ optdepends = wallutils: Timed wallpapers
+ optdepends = waybar: Highly customizable bar
+ provides = sway
+ conflicts = sway
+ options = debug
+ backup = etc/sway/config
+ source = sway::git+https://github.com/RagnarGrootKoerkamp/sway.git#branch=fakefullscreen
+ source = 50-systemd-user.conf
+ sha512sums = SKIP
+ sha512sums = 57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e
+
+pkgname = sway-inhibit-fullscreen-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..838883bd38e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+.*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!50-systemd-user.conf
diff --git a/50-systemd-user.conf b/50-systemd-user.conf
new file mode 100644
index 000000000000..72e5dcd98b02
--- /dev/null
+++ b/50-systemd-user.conf
@@ -0,0 +1,7 @@
+# sway does not set DISPLAY/WAYLAND_DISPLAY in the systemd user environment
+# See FS#63021
+# Adapted from xorg's 50-systemd-user.sh, which achieves a similar goal.
+
+exec systemctl --user import-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK
+exec hash dbus-update-activation-environment 2>/dev/null && \
+ dbus-update-activation-environment --systemd DISPLAY WAYLAND_DISPLAY SWAYSOCK
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7295004c19bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: Ragnar Groot Koerkamp <ragnar dot grootkoerkamp at gmail dot com>
+# Contributor: Drew DeVault <sir@cmpwn.com>
+# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
+pkgname=sway-inhibit-fullscreen-git
+_pkgname=sway
+pkgver=r6655.7036c198
+pkgrel=1
+license=("MIT")
+pkgdesc="Sway with inhibit_fullscreen command"
+makedepends=(
+ "git"
+ "meson"
+ "scdoc"
+ "wayland-protocols"
+)
+depends=(
+ "cairo"
+ "gdk-pixbuf2"
+ "json-c"
+ "pango"
+ "polkit"
+ "pcre"
+ "swaybg"
+ "ttf-font"
+ "wlroots"
+ "xorg-server-xwayland"
+)
+optdepends=(
+ "alacritty: Terminal emulator used by the default config"
+ "dmenu: Application launcher"
+ "grim: Screenshot utility"
+ "i3status: Status line"
+ "mako: Lightweight notification daemon"
+ "slurp: Select a region"
+ "swayidle: Idle management daemon"
+ "swaylock: Screen locker"
+ "wallutils: Timed wallpapers"
+ "waybar: Highly customizable bar"
+)
+backup=(etc/sway/config)
+arch=("i686" "x86_64")
+url="https://swaywm.org"
+source=("${_pkgname}::git+https://github.com/RagnarGrootKoerkamp/sway.git#branch=fakefullscreen"
+ 50-systemd-user.conf)
+sha512sums=('SKIP'
+ '57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e')
+provides=("sway")
+conflicts=("sway")
+options=(debug)
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ arch-meson \
+ -Dsd-bus-provider=libsystemd \
+ -Dwerror=false \
+ "$_pkgname" build
+ meson compile -C build
+}
+
+package() {
+ install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
+
+ DESTDIR="$pkgdir" meson install -C build
+
+ cd "$_pkgname"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
+ install -Dm755 "contrib/$util" -t "$pkgdir/usr/share/$pkgname/scripts"
+ done
+}
+
+post_upgrade() {
+ # This is currently based on sway 1.6, which goes together with the version of wlroots in community.
+ #echo "Make sure to upgrade wlroots-git and sway-git together."
+ #echo "Upgrading one but not the other is unsupported."
+ :
+}