summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO48
-rw-r--r--.gitignore4
-rw-r--r--0001-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch24
-rw-r--r--10-systemd.conf10
-rw-r--r--PKGBUILD71
-rw-r--r--sway-session.target8
-rw-r--r--sway.service16
7 files changed, 181 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8903fa059198
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = sway9
+ pkgdesc = Tiling Wayland compositor and replacement for the i3 window manager (personal build)
+ pkgver = 1.2
+ pkgrel = 1
+ epoch = 1
+ url = https://swaywm.org/
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = scdoc
+ makedepends = setconf
+ makedepends = wayland-protocols
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = json-c
+ depends = pango
+ depends = pcre
+ depends = swaybg
+ depends = ttf-font
+ depends = wlroots
+ optdepends = dmenu: Application launcher
+ optdepends = i3status: Status line
+ optdepends = grim: Screenshot utility
+ optdepends = mako: Lightweight notification daemon
+ optdepends = rxvt-unicode: Terminal emulator
+ optdepends = slurp: Select a region
+ optdepends = swayidle: Idle management daemon
+ optdepends = swaylock: Screen locker
+ optdepends = wallutils: Timed wallpapers
+ optdepends = waybar: Highly customizable bar
+ optdepends = xorg-server-xwayland: X11 support
+ provides = sway
+ conflicts = sway
+ backup = etc/sway/config
+ source = https://github.com/swaywm/sway/releases/download/1.2/sway-1.2.tar.gz
+ source = https://github.com/swaywm/sway/releases/download/1.2/sway-1.2.tar.gz.sig
+ source = 10-systemd.conf
+ source = 0001-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch
+ validpgpkeys = 9DDA3B9FA5D58DD5392C78E652CB6609B22DA89A
+ sha512sums = e3842e0da58a1678289aa24fc84f6841deeea6e9ffe04407525e5b9d62ed177d890133ff07412317c811f5b07a2e5073d14ff59a30e62111f51fc65af0dddb19
+ sha512sums = SKIP
+ sha512sums = 122b97f7adb6444c442368c5bbbd3401bcd8420f522fcd6521def5a09cd2989f5f6f555a5a7762e922eaa307077eb26db6508242ee1b835ca73ad65acaeef95b
+ sha512sums = f53647efd2686491a42d46ab9e1fb72d32136795cd2b77eebd809ca85bbc11629715ae159de1bc83a2b1991fba61bb7a08407d22fd7b715d17693aafa235a6e8
+
+pkgname = sway9
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..984a66f8ea06
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+sway-*.tar.gz*
+*.pkg.tar*
diff --git a/0001-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch b/0001-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch
new file mode 100644
index 000000000000..71e6f92bf130
--- /dev/null
+++ b/0001-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch
@@ -0,0 +1,24 @@
+From 5b960da9e6cf68c0338bd8ab8c0c3625f0c98cb0 Mon Sep 17 00:00:00 2001
+From: Dan Elkouby <streetwalkermc@gmail.com>
+Date: Fri, 27 Dec 2019 15:21:31 +0200
+Subject: [PATCH] Don't send wl_pointer_leave when hide_cursor activates
+
+---
+ sway/input/cursor.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/sway/input/cursor.c b/sway/input/cursor.c
+index 680fe39e..86650f08 100644
+--- a/sway/input/cursor.c
++++ b/sway/input/cursor.c
+@@ -176,7 +176,6 @@ void cursor_rebase_all(void) {
+ static void cursor_hide(struct sway_cursor *cursor) {
+ wlr_cursor_set_image(cursor->cursor, NULL, 0, 0, 0, 0, 0, 0);
+ cursor->hidden = true;
+- wlr_seat_pointer_clear_focus(cursor->seat->wlr_seat);
+ }
+
+ static int hide_notify(void *data) {
+--
+2.24.1
+
diff --git a/10-systemd.conf b/10-systemd.conf
new file mode 100644
index 000000000000..af7484bba3ef
--- /dev/null
+++ b/10-systemd.conf
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+# FS#63021
+#
+
+systemctl --user import-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK XCURSOR_SIZE
+
+if command -v dbus-update-activation-environment >/dev/null 2>&1; then
+ dbus-update-activation-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK XCURSOR_SIZE
+fi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f010f422d86f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Dan Elkouby <streetwalkermc@gmail.com>
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+
+_pkgname=sway
+pkgname=sway9
+pkgver=1.2
+epoch=1
+pkgrel=1
+pkgdesc='Tiling Wayland compositor and replacement for the i3 window manager (personal build)'
+arch=(x86_64)
+url='https://swaywm.org/'
+license=(MIT)
+depends=(cairo gdk-pixbuf2 json-c pango pcre swaybg ttf-font wlroots)
+makedepends=(git meson ninja scdoc setconf wayland-protocols)
+provides=(sway)
+conflicts=(sway)
+backup=(etc/sway/config)
+optdepends=(
+ 'dmenu: Application launcher'
+ 'i3status: Status line'
+ 'grim: Screenshot utility'
+ 'mako: Lightweight notification daemon'
+ 'rxvt-unicode: Terminal emulator'
+ 'slurp: Select a region'
+ 'swayidle: Idle management daemon'
+ 'swaylock: Screen locker'
+ 'wallutils: Timed wallpapers'
+ 'waybar: Highly customizable bar'
+ 'xorg-server-xwayland: X11 support'
+)
+source=("https://github.com/swaywm/sway/releases/download/$pkgver/sway-$pkgver.tar.gz"
+ "https://github.com/swaywm/sway/releases/download/$pkgver/sway-$pkgver.tar.gz.sig"
+ "10-systemd.conf"
+ "0001-Don-t-send-wl_pointer_leave-when-hide_cursor-activat.patch")
+sha512sums=('e3842e0da58a1678289aa24fc84f6841deeea6e9ffe04407525e5b9d62ed177d890133ff07412317c811f5b07a2e5073d14ff59a30e62111f51fc65af0dddb19'
+ 'SKIP'
+ '122b97f7adb6444c442368c5bbbd3401bcd8420f522fcd6521def5a09cd2989f5f6f555a5a7762e922eaa307077eb26db6508242ee1b835ca73ad65acaeef95b'
+ 'f53647efd2686491a42d46ab9e1fb72d32136795cd2b77eebd809ca85bbc11629715ae159de1bc83a2b1991fba61bb7a08407d22fd7b715d17693aafa235a6e8')
+validpgpkeys=('9DDA3B9FA5D58DD5392C78E652CB6609B22DA89A') # Drew DeVault
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+
+ # Set the version information to 'Arch Linux' instead of 'makepkg'
+ sed -i "s/branch \\\'@1@\\\'/Arch Linux/g" meson.build
+
+ # From the linux-mainline PKGBUILD
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ msg2 "Applying patch $src..."
+ patch -Np1 < "../$src"
+ done
+}
+
+build() {
+ mkdir -p build
+ arch-meson build "$_pkgname-$pkgver" -D werror=false -D b_ndebug=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm644 "$_pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 10-systemd.conf "$pkgdir/etc/sway/conf.d/10-systemd.conf"
+}
+
+# vim: ts=2 sw=2 et
diff --git a/sway-session.target b/sway-session.target
new file mode 100644
index 000000000000..20cc51992749
--- /dev/null
+++ b/sway-session.target
@@ -0,0 +1,8 @@
+# https://github.com/swaywm/sway/wiki/Systemd-integration
+
+[Unit]
+Description=sway compositor session
+Documentation=man:systemd.special(7)
+BindsTo=graphical-session.target
+Wants=graphical-session-pre.target
+After=graphical-session-pre.target
diff --git a/sway.service b/sway.service
new file mode 100644
index 000000000000..c53c9db7ce1b
--- /dev/null
+++ b/sway.service
@@ -0,0 +1,16 @@
+# https://github.com/swaywm/sway/wiki/Systemd-integration
+
+[Unit]
+Description=sway - SirCmpwn's Wayland window manager
+Documentation=man:sway(5)
+BindsTo=graphical-session.target
+Wants=graphical-session-pre.target
+After=graphical-session-pre.target
+
+[Service]
+Type=simple
+EnvironmentFile=-%h/.config/sway/env
+ExecStart=/usr/bin/sway
+Restart=on-failure
+RestartSec=1
+TimeoutStopSec=10