summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b12cd729134e..0ff10d3a12ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = swayshot
pkgdesc = Sway screenshots: screen, window or region.
- pkgver = 2.2.0
- pkgrel = 2
+ pkgver = 2.3.0
+ pkgrel = 1
url = https://gitlab.com/radio_rogal/swayshot
arch = any
- license = Apache
+ license = GPL3
depends = sway
depends = xdg-user-dirs
depends = grim
@@ -13,9 +13,10 @@ pkgbase = swayshot
optdepends = wl-clipboard: copy the full path to clipboard
optdepends = xsel: copy the full path to clipboard
optdepends = xclip: copy the full path to clipboard
+ optdepends = curl: upload a screenshot to x0.at
conflicts = swaygrab-helper
- source = https://gitlab.com/radio_rogal/swayshot/-/archive/2.2.0/swayshot-2.2.0.tar.bz2
- sha256sums = 4cb7f6317f79b7396940464c8a5974bdc5fe01f546f0a6920ea4d7060f848e01
+ source = https://gitlab.com/radio_rogal/swayshot/-/archive/2.3.0/swayshot-2.3.0.tar.bz2
+ sha256sums = ece411f2fe889dc6baf1288801f5659f277f7b296fc06a269323b22649d94bc6
pkgname = swayshot
diff --git a/PKGBUILD b/PKGBUILD
index c5c51e4e63d7..b2dd22911e8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: Vitaliy Berdinskikh <ur6lad at gmail dot com>
pkgname=swayshot
-pkgver=2.2.0
-pkgrel=2
+pkgver=2.3.0
+pkgrel=1
pkgdesc='Sway screenshots: screen, window or region.'
arch=('any')
url='https://gitlab.com/radio_rogal/swayshot'
-license=('Apache')
+license=('GPL3')
depends=('sway' 'xdg-user-dirs' 'grim' 'slurp' 'jq')
optdepends=('wl-clipboard: copy the full path to clipboard'
'xsel: copy the full path to clipboard'
- 'xclip: copy the full path to clipboard')
+ 'xclip: copy the full path to clipboard'
+ 'curl: upload a screenshot to x0.at')
conflicts=('swaygrab-helper')
source=(https://gitlab.com/radio_rogal/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2)
-sha256sums=('4cb7f6317f79b7396940464c8a5974bdc5fe01f546f0a6920ea4d7060f848e01')
+sha256sums=('ece411f2fe889dc6baf1288801f5659f277f7b296fc06a269323b22649d94bc6')
package() {
cd "$srcdir"/$pkgname-$pkgver
install -d "$pkgdir"/etc/sway/config.d
- install -m 644 $pkgname.config "$pkgdir"/etc/sway/config.d/$pkgname
+ install -m 644 $pkgname.conf "$pkgdir"/etc/sway/config.d
install -d "$pkgdir"/usr/bin
install -m 755 $pkgname.sh "$pkgdir"/usr/bin/$pkgname
}