summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rwxr-xr-xfurniturelibraryeditor3
-rwxr-xr-xfurniturelibraryeditor.desktop9
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d00112dda49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sweethome3d-furniture-library
+ pkgdesc = A tool to manage furniture in Sweet Home 3D
+ pkgver = 1.13
+ pkgrel = 1
+ url = http://www.sweethome3d.com/support/forum/viewthread_thread,1550
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = java-runtime
+ depends = sweethome3d
+ source = http://downloads.sourceforge.net/project/sweethome3d/FurnitureLibraryEditor/FurnitureLibraryEditor-1.13.jar
+ source = furniturelibraryeditor
+ source = furniturelibraryeditor.desktop
+ md5sums = 66c5f967f75c76fb88c9359732b248d1
+ md5sums = c8980c9deb00e2b167115f795876d7db
+ md5sums = 152c91ee7b4098c11492f80a587ed64a
+
+pkgname = sweethome3d-furniture-library
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..128de53836fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
+# Maintainer: Elliott Seyler <emhs@mossberg>
+# Maintainer: Jenya Sovetkin <e dot sovetkin at gmail dot com>
+pkgname=sweethome3d-furniture-library
+pkgver=1.13
+pkgrel=1
+pkgdesc="A tool to manage furniture in Sweet Home 3D"
+arch=('i686' 'x86_64')
+url="http://www.sweethome3d.com/support/forum/viewthread_thread,1550"
+license=('GPL')
+depends=('java-runtime' 'sweethome3d')
+makedepends=('unzip')
+source=("http://downloads.sourceforge.net/project/sweethome3d/FurnitureLibraryEditor/FurnitureLibraryEditor-$pkgver.jar"
+ 'furniturelibraryeditor'
+ 'furniturelibraryeditor.desktop')
+md5sums=('66c5f967f75c76fb88c9359732b248d1'
+ 'c8980c9deb00e2b167115f795876d7db'
+ '152c91ee7b4098c11492f80a587ed64a')
+
+prepare() {
+ echo 'cat <<END_OF_TEXT' > temp.sh
+ cat furniturelibraryeditor.desktop >> temp.sh
+ echo 'END_OF_TEXT' >> temp.sh
+ bash temp.sh > furniturelibraryeditor.desktop
+ rm temp.sh
+}
+
+package() {
+
+ mv com/eteks/furniturelibraryeditor/swing/resources/aboutIcon.png furniturelibraryeditor.png
+ mkdir -p $pkgdir/usr/share/java
+ mkdir -p $pkgdir/usr/share/pixmaps
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/share/applications
+ cp FurnitureLibraryEditor-$pkgver.jar $pkgdir/usr/share/java/furniturelibraryeditor.jar
+ cp furniturelibraryeditor.png $pkgdir/usr/share/pixmaps
+ cp furniturelibraryeditor $pkgdir/usr/bin
+ cp furniturelibraryeditor.desktop $pkgdir/usr/share/applications
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/furniturelibraryeditor b/furniturelibraryeditor
new file mode 100755
index 000000000000..6655a928f246
--- /dev/null
+++ b/furniturelibraryeditor
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+/usr/bin/java -jar /usr/share/java/furniturelibraryeditor.jar
diff --git a/furniturelibraryeditor.desktop b/furniturelibraryeditor.desktop
new file mode 100755
index 000000000000..6aacafd22d16
--- /dev/null
+++ b/furniturelibraryeditor.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=
+Type=Application
+Name=Furniture Library Editor
+Comment=An interior design application
+TryExec=/usr/bin/furniturelibraryeditor
+Exec=furniturelibraryeditor
+Icon=/usr/share/pixmaps/furniturelibraryeditor.png
+Categories=Office;Java;