summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--swfmill.patch12
3 files changed, 4 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0db521407aad..c6581e5448c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Oct 25 14:51:03 UTC 2016
pkgbase = swfmill-git
pkgdesc = xml2swf and swf2xml processor with import functionalities
- pkgver = r472.28d51a7
+ pkgver = r543.53d7690
pkgrel = 1
url = http://swfmill.org
arch = i686
@@ -14,9 +12,7 @@ pkgbase = swfmill-git
provides = swfmill
conflicts = swfmill
source = git+https://github.com/djcsdy/swfmill
- source = swfmill.patch
md5sums = SKIP
- md5sums = 040743a3be51f078b64fbb855183ca60
pkgname = swfmill-git
diff --git a/PKGBUILD b/PKGBUILD
index 4b149dac8c63..0584f44142d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: anonymous <https://gist.github.com/anonymous/2924244>
_pkgname=swfmill
pkgname=$_pkgname-git
-pkgver=r472.28d51a7
+pkgver=r543.53d7690
pkgrel=1
pkgdesc="xml2swf and swf2xml processor with import functionalities"
arch=('i686' 'x86_64')
@@ -11,10 +11,8 @@ license=('GPL')
depends=('libxslt' 'freetype2' 'libpng')
provides=('swfmill')
conflicts=('swfmill')
-source=("git+https://github.com/djcsdy/swfmill"
- swfmill.patch)
-md5sums=('SKIP'
- '040743a3be51f078b64fbb855183ca60')
+source=("git+https://github.com/djcsdy/swfmill")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -23,8 +21,6 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
-
- patch --forward -p1 -i "$srcdir/$_pkgname.patch"
}
build() {
diff --git a/swfmill.patch b/swfmill.patch
deleted file mode 100644
index 164000de0f1d..000000000000
--- a/swfmill.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru swfmill-0.3.3_/src/swft/swft_import_jpeg.cpp swfmill-0.3.3/src/swft/swft_import_jpeg.cpp
---- swfmill-0.3.3_/src/swft/swft_import_jpeg.cpp 2016-10-25 14:28:36.560342480 +0000
-+++ swfmill-0.3.3/src/swft/swft_import_jpeg.cpp 2016-10-25 14:27:42.640012522 +0000
-@@ -10,7 +10,7 @@
- #include <zlib.h>
-
- #define TMP_STRLEN 0xff
--const char jpeg_header[] = { 0xff, 0xd9, 0xff, 0xd8, 0 };
-+const char jpeg_header[] = { (char)0xff, (char)0xd9, (char)0xff, (char)0xd8, 0 };
-
- // defined in swft_import_png
- bool compress( unsigned char *inputBuffer, int inLength, unsigned char *outputBuffer, int *outLength );