summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD33
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1898f3597581..62c24d2154ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swhkd-git
pkgdesc = A display server independent hotkey daemon inspired by sxhkd.
- pkgver = 1
+ pkgver = .543.gf6ea9d6
pkgrel = 1
url = https://github.com/waycrate/swhkd
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = swhkd-git
makedepends = scdoc
depends = polkit
conflicts = swhkd-musl-git
- source = swhkd::git+https://github.com/waycrate/swhkd
+ source = swhkd::git+https://github.com/waycrate/swhkd.git
sha256sums = SKIP
pkgname = swhkd-git
diff --git a/PKGBUILD b/PKGBUILD
index 557dbf20c1f3..bcebfc5eddaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: Aakash Sharma <aakashsensharma@gmail.com>
# Contributor: Sergey A. <murlakatamenka@disroot.org>
+# Contributor: rv178 <idliyout@gmail.com>
-pkgname='swhkd-git'
_pkgname="swhkd"
-pkgver=1
+pkgname="${_pkgname}-git"
+pkgver=.543.gf6ea9d6
pkgrel=1
-arch=('x86_64')
+arch=("x86_64")
url="https://github.com/waycrate/swhkd"
pkgdesc="A display server independent hotkey daemon inspired by sxhkd."
-license=('BSD')
-depends=('polkit')
-makedepends=('rustup' 'make' 'git' 'scdoc')
-conflicts=('swhkd-musl-git')
-source=("$_pkgname::git+https://github.com/waycrate/$_pkgname")
-sha256sums=('SKIP')
+license=("BSD")
+depends=("polkit")
+makedepends=("rustup" "make" "git" "scdoc")
+conflicts=("swhkd-musl-git")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=("SKIP")
build(){
cd "$_pkgname"
- scdoc < ./swhkd.1.scd > swhkd.1.gz
- scdoc < ./swhks.1.scd > swhks.1.gz
- scdoc < ./swhkd.5.scd > swhkd.5.gz
- scdoc < ./swhkd-keys.5.scd > swhkd-keys.5.gz
+ scdoc < ./docs/swhkd.1.scd > ./docs/swhkd.1.gz
+ scdoc < ./docs/swhks.1.scd > ./docs/swhks.1.gz
+ scdoc < ./docs/swhkd.5.scd > ./docs/swhkd.5.gz
+ scdoc < ./docs/swhkd-keys.5.scd > ./docs/swhkd-keys.5.gz
make setup
make
}
@@ -31,11 +32,11 @@ package() {
install -Dm 755 ./target/release/swhks "$pkgdir/usr/bin/swhks"
install -Dm 644 -o root ./com.github.swhkd.pkexec.policy -t "$pkgdir/usr/share/polkit-1/actions"
- install -Dm 644 ./*.1.gz -t "$pkgdir/usr/share/man/man1/"
- install -Dm 644 ./*.5.gz -t "$pkgdir/usr/share/man/man5/"
+ install -Dm 644 ./docs/*.1.gz -t "$pkgdir/usr/share/man/man1/"
+ install -Dm 644 ./docs/*.5.gz -t "$pkgdir/usr/share/man/man5/"
}
pkgver() {
cd $_pkgname
- echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+ echo "$(grep "^version =" Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}