summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd364f79528a..8a0658909e83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swift-bin
pkgdesc = Official binary builds of the Swift programming language.
pkgver = 4.1
- pkgrel = 2
+ pkgrel = 3
url = https://swift.org
arch = x86_64
license = apache
diff --git a/PKGBUILD b/PKGBUILD
index 347027a163ef..a63ac4c82cb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_version=4.1
pkgname=swift-bin
pkgver=${_version//-/.}
-pkgrel=2
+pkgrel=3
pkgdesc="Official binary builds of the Swift programming language."
arch=('x86_64')
url="https://swift.org"
@@ -39,8 +39,8 @@ package() {
for file in "${target}/bin/"*; do
ln -s ../lib/swift/bin/"`basename "$file"`" "${pkgdir}/usr/bin"
done
- ln -s swift/lib/libsourcekitdInProc.so "${pkgdir}/usr/lib"
- chmod +x swift/lib/libsourcekitdInProc.so
+ ln -sf "../lib/swift/lib/libsourcekitdInProc.so" "${pkgdir}/usr/lib"
+ chmod +x "${target}/lib/libsourcekitdInProc.so"
# Yuck! patching libedit and libcurl SONAMEs
find "${target}/bin" -type f -exec sed -i 's/libedit\.so\.2/libedit\.so\.0/g' {} \;