summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xrun.sh8
3 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff80743d343a..fcd9a57000b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swish
pkgdesc = SWI-Prolog for SHaring: a SWI-Prolog web IDE
pkgver = r1150.55fec5a
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SWI-Prolog/swish
install = .install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 36969d791f41..71a43eeac463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
pkgname=swish
pkgver=r1150.55fec5a
-pkgrel=1
+pkgrel=2
pkgdesc="SWI-Prolog for SHaring: a SWI-Prolog web IDE"
arch=('x86_64')
url="https://github.com/SWI-Prolog/swish"
diff --git a/run.sh b/run.sh
index f7ffc493c05f..f4309db4493d 100755
--- a/run.sh
+++ b/run.sh
@@ -65,6 +65,11 @@ init()
:
}
+remove()
+{
+ :
+}
+
startd()
{
local pid=""
@@ -130,11 +135,12 @@ write_pid_file()
option_parser()
{
- getopts ":hiks" opt "$@"
+ getopts ":hikrs" opt "$@"
case "$opt" in
h ) help ;;
i ) init ;;
k ) killd ;;
+ r ) remove ;;
s ) startd ;;
? ) help; return 1 ;;
esac