summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.install4
-rw-r--r--PKGBUILD2
-rwxr-xr-xrun.sh5
4 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f13de9350f7..1c048362ac71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = swish
pkgdesc = SWI-Prolog for SHaring: a SWI-Prolog web IDE
pkgver = r1124.071295b
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SWI-Prolog/swish
install = .install
arch = x86_64
diff --git a/.install b/.install
index 5e53d53b0b45..f5c15b9427ac 100644
--- a/.install
+++ b/.install
@@ -10,3 +10,7 @@ post_install() {
swish.service to run the server.\n\n"
}
+post_remove()
+{
+ printf "\n\nYou can remove swish user and group.\n\n"
+}
diff --git a/PKGBUILD b/PKGBUILD
index 5f9391b760cf..dc52c5966c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
pkgname=swish
pkgver=r1124.071295b
-pkgrel=1
+pkgrel=2
pkgdesc="SWI-Prolog for SHaring: a SWI-Prolog web IDE"
arch=('x86_64')
url="https://github.com/SWI-Prolog/swish"
diff --git a/run.sh b/run.sh
index a4721e3bc488..7a446416fff5 100755
--- a/run.sh
+++ b/run.sh
@@ -65,7 +65,10 @@ startd()
local pid=""
{
- ( exec swipl --quiet -f "$pkg_dir"/run.pl ) &
+ (
+ cd "$pkg_dir"
+ exec swipl --quiet -f "$pkg_dir"/run.pl
+ ) &
pid="$!"
} 1>/dev/null 2>/dev/null