summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--MKPKG5
-rw-r--r--PKGBUILD45
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb97c5e285d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+# Generated by mksrcinfo v8
+# Tue Aug 16 18:56:56 UTC 2016
+pkgbase = switchboard-plug-online-accounts
+ pkgdesc = Online Accounts plug for Switchboard
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://launchpad.net/switchboard-plug-onlineaccounts
+ arch = i686
+ arch = x86_64
+ groups = pantheon
+ license = GPL3
+ makedepends = cmake
+ makedepends = vala
+ depends = glib2
+ depends = glibc
+ depends = gsignond-extension-pantheon-bzr
+ depends = gsignond-plugin-oauth-git
+ depends = gsignond-plugin-sasl-git
+ depends = gtk3
+ depends = json-glib
+ depends = libaccounts-glib
+ depends = libgee
+ depends = libgsignon-glib
+ depends = rest
+ depends = webkit2gtk
+ depends = libgranite.so
+ depends = libswitchboard-2.0.so
+ source = https://launchpad.net/switchboard-plug-onlineaccounts/loki/0.3/+download/switchboard-plug-onlineaccounts-0.3.tar.xz
+ sha256sums = 76864fedb90b60239aabc51cde494b7ae8d1a1f8b966e1d4d0a2ba1e1065c0b6
+
+pkgname = switchboard-plug-online-accounts
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..c963af23e12a
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,5 @@
+pkgname=('switchboard-plug-online-accounts')
+builddeps=('gsignond' 'gsignond-plugin-oauth-git' 'gsignond-plugin-sasl-git'
+ 'gsignond-extension-pantheon-bzr' 'switchboard')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83507e32c29b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=switchboard-plug-online-accounts
+pkgver=0.3
+pkgrel=1
+pkgdesc='Online Accounts plug for Switchboard'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/switchboard-plug-onlineaccounts'
+license=('GPL3')
+groups=('pantheon')
+depends=('glib2' 'glibc' 'gsignond-extension-pantheon-bzr'
+ 'gsignond-plugin-oauth-git' 'gsignond-plugin-sasl-git' 'gtk3'
+ 'json-glib' 'libaccounts-glib' 'libgee' 'libgsignon-glib' 'rest'
+ 'webkit2gtk'
+ 'libgranite.so' 'libswitchboard-2.0.so')
+makedepends=('cmake' 'vala')
+source=("https://launchpad.net/switchboard-plug-onlineaccounts/loki/${pkgver}/+download/switchboard-plug-onlineaccounts-${pkgver}.tar.xz")
+sha256sums=('76864fedb90b60239aabc51cde494b7ae8d1a1f8b966e1d4d0a2ba1e1065c0b6')
+
+prepare() {
+ cd switchboard-plug-onlineaccounts-${pkgver}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd switchboard-plug-onlineaccounts-${pkgver}/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd switchboard-plug-onlineaccounts-${pkgver}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: