summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD67
1 files changed, 33 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a487259fbf6f..65685a5b8993 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,38 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-online-accounts-git
-pkgver=r488.369e470
+pkgver=r700.75586db
pkgrel=1
pkgdesc='Switchboard Online Accounts Plug'
-arch=('x86_64')
-url='https://github.com/elementary/switchboard-plug-onlineaccounts'
-license=('GPL2')
-groups=('pantheon-unstable')
-depends=('glib2' 'glibc' 'gsignond-extension-pantheon-git'
- 'gsignond-plugin-oauth-git' 'gsignond-plugin-sasl-git' 'gtk3'
- 'json-glib' 'libaccounts-glib' 'libgee' 'libgsignon-glib' 'rest'
- 'webkit2gtk'
- 'libgranite.so' 'libswitchboard-2.0.so')
-makedepends=('cmake' 'git' 'granite-git' 'switchboard-git' 'vala')
-provides=('switchboard-plug-online-accounts')
-conflicts=('switchboard-plug-online-accounts')
-source=('switchboard-plug-online-accounts::git+https://github.com/elementary/switchboard-plug-onlineaccounts.git')
-sha256sums=('SKIP')
+arch=(x86_64)
+url=https://github.com/elementary/switchboard-plug-onlineaccounts
+license=(GPL2)
+groups=(pantheon-unstable)
+depends=(
+ glib2
+ glibc
+ gtk3
+ json-glib
+ libaccounts-glib
+ libgee
+ libgranite.so
+ libgsignon-glib
+ libsignon-glib
+ libswitchboard-2.0.so
+ rest
+ webkit2gtk
+)
+makedepends=(
+ git
+ granite-git
+ meson
+ switchboard-git
+ vala
+)
+provides=(switchboard-plug-online-accounts)
+conflicts=(switchboard-plug-online-accounts)
+source=(switchboard-plug-online-accounts::git+https://github.com/elementary/switchboard-plug-onlineaccounts.git)
+sha256sums=(SKIP)
pkgver() {
cd switchboard-plug-online-accounts
@@ -25,29 +40,13 @@ pkgver() {
echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
-prepare() {
- cd switchboard-plug-online-accounts
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
-}
-
build() {
- cd switchboard-plug-online-accounts/build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib'
- make
+ arch-meson switchboard-plug-online-accounts build
+ ninja -C build
}
package() {
- cd switchboard-plug-online-accounts/build
-
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: