summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD53
2 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7c9e2ff78de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+# Generated by mksrcinfo v8
+# Mon May 1 19:58:08 UTC 2017
+pkgbase = switchboard-plug-online-accounts-git
+ pkgdesc = Switchboard Online Accounts Plug
+ pkgver = r446.5a0270a
+ pkgrel = 1
+ url = https://github.com/elementary/switchboard-plug-onlineaccounts
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = granite-git
+ makedepends = switchboard-git
+ makedepends = vala
+ depends = glib2
+ depends = glibc
+ depends = gsignond-extension-pantheon-bzr
+ depends = gsignond-plugin-oauth-git
+ depends = gsignond-plugin-sasl-git
+ depends = gtk3
+ depends = json-glib
+ depends = libaccounts-glib
+ depends = libgee
+ depends = libgsignon-glib
+ depends = rest
+ depends = webkit2gtk
+ depends = libgranite.so
+ depends = libswitchboard-2.0.so
+ provides = switchboard-plug-online-accounts
+ conflicts = switchboard-plug-online-accounts
+ source = switchboard-plug-online-accounts::git+https://github.com/elementary/switchboard-plug-onlineaccounts.git
+ sha256sums = SKIP
+
+pkgname = switchboard-plug-online-accounts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04af69da9aec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=switchboard-plug-online-accounts-git
+pkgver=r446.5a0270a
+pkgrel=1
+pkgdesc='Switchboard Online Accounts Plug'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/switchboard-plug-onlineaccounts'
+license=('GPL2')
+groups=('pantheon-unstable')
+depends=('glib2' 'glibc' 'gsignond-extension-pantheon-bzr'
+ 'gsignond-plugin-oauth-git' 'gsignond-plugin-sasl-git' 'gtk3'
+ 'json-glib' 'libaccounts-glib' 'libgee' 'libgsignon-glib' 'rest'
+ 'webkit2gtk'
+ 'libgranite.so' 'libswitchboard-2.0.so')
+makedepends=('cmake' 'git' 'granite-git' 'switchboard-git' 'vala')
+provides=('switchboard-plug-online-accounts')
+conflicts=('switchboard-plug-online-accounts')
+source=('switchboard-plug-online-accounts::git+https://github.com/elementary/switchboard-plug-onlineaccounts.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd switchboard-plug-online-accounts
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd switchboard-plug-online-accounts
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd switchboard-plug-online-accounts/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd switchboard-plug-online-accounts/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: