summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4504762b777f..9dec8ce1fa40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = switchhosts-bin
pkgdesc = Switch hosts quickly!
- pkgver = 4.1.1
- pkgrel = 2
+ pkgver = 4.1.2
+ pkgrel = 1
url = https://swh.app/
arch = x86_64
license = APACHE
@@ -16,9 +16,11 @@ pkgbase = switchhosts-bin
depends = libsecret
optdepends = libappindicator-gtk3
options = !strip
- source = https://github.com/oldj/SwitchHosts/releases/download/v4.1.1/SwitchHosts_linux_amd64_4.1.1.6077.deb
+ source = https://github.com/oldj/SwitchHosts/releases/download/v4.1.2/SwitchHosts_linux_amd64_4.1.2.6086.deb
+ source = https://github.com/oldj/SwitchHosts/blob/master/src/assets/icon.png
source = https://raw.githubusercontent.com/oldj/SwitchHosts/master/LICENSE
- sha256sums = 1793245d257818e0a29ab4ea1481af06f56fbbefc96981f9f3b2eb77755ffb67
- sha256sums = c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4
+ sha256sums = a2898640645392952836b8d8d9e7d3edc135b87e2d15c35c13ad567fb333a8b5
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = switchhosts-bin
diff --git a/.gitignore b/.gitignore
index 85a54e28cad2..6680e51174e8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
/LICENSE
/SwitchHosts*.deb
+/icon.png
diff --git a/PKGBUILD b/PKGBUILD
index a8b2944aa3ad..742599d42ee1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Berturion@free.fr>
pkgname=switchhosts-bin
-pkgver=4.1.1
-pkgrel=2
+pkgver=4.1.2
+pkgrel=1
pkgdesc='Switch hosts quickly!'
arch=(x86_64)
url=https://swh.app/
@@ -21,16 +21,20 @@ depends=(
libsecret
)
optdepends=(libappindicator-gtk3)
-source=(https://github.com/oldj/SwitchHosts/releases/download/v4.1.1/SwitchHosts_linux_amd64_4.1.1.6077.deb
+source=(https://github.com/oldj/SwitchHosts/releases/download/v4.1.2/SwitchHosts_linux_amd64_4.1.2.6086.deb
+ https://github.com/oldj/SwitchHosts/blob/master/src/assets/icon.png
https://raw.githubusercontent.com/oldj/SwitchHosts/master/LICENSE)
-sha256sums=('1793245d257818e0a29ab4ea1481af06f56fbbefc96981f9f3b2eb77755ffb67'
- 'c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4')
+sha256sums=(
+ a2898640645392952836b8d8d9e7d3edc135b87e2d15c35c13ad567fb333a8b5
+ SKIP
+ SKIP
+)
package() {
bsdtar -xf $srcdir/data.tar.xz -C $pkgdir
mkdir -p $pkgdir/usr/{bin,share/pixmaps}/
- mv $pkgdir/usr/share/{icons/hicolor/0x0/apps,pixmaps}/switchhosts.png
- rm -rf $pkgdir/usr/share/{doc,icons}
+ rm -rf $pkgdir/usr/share/doc
ln -s /opt/SwitchHosts/switchhosts $pkgdir/usr/bin/
+ install -Dm644 icon.png $pkgdir/usr/share/pixmaps/switchhosts.png
install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
}