summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD41
-rw-r--r--switchhosts-bin.desktop8
-rw-r--r--switchhosts-bin.install11
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0e375da9a04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = switchhosts-bin
+ pkgdesc = Switch hosts quickly!
+ pkgver = 3.3.6
+ pkgrel = 5287
+ url = https://oldj.github.io/SwitchHosts
+ arch = any
+ license = MIT
+ makedepends = imagemagick
+ makedepends = npm
+ depends = gconf
+ depends = gtk2
+ depends = libnotify
+ depends = libxtst
+ depends = nss
+ depends = python2
+ depends = xdg-utils
+ depends = desktop-file-utils
+ depends = alsa-lib
+ options = !strip
+ source = https://github.com/oldj/SwitchHosts/releases/download/v3.3.6/SwitchHosts-linux-x64_v3.3.6.5287.zip
+ source = https://raw.githubusercontent.com/oldj/SwitchHosts/master/assets/app.ico
+ source = switchhosts-bin.install
+ source = switchhosts-bin.desktop
+ md5sums = c051e239ce81a89d22b14c099c1afd66
+ md5sums = 88fe4a72cf9630119dd512c91b54edd9
+ md5sums = 0b6211b511da48346cecdc1d2f963c76
+ md5sums = 30df36e53ef2d815a2c2395f0378f9bb
+
+pkgname = switchhosts-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14c318238615
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgname=switchhosts-bin
+pkgver=3.3.6
+pkgrel=5287
+pkgdesc="Switch hosts quickly!"
+arch=('any')
+url="https://oldj.github.io/SwitchHosts"
+license=("MIT")
+options=(!strip)
+depends=("gconf" "gtk2" "libnotify" "libxtst" "nss" "python2" "xdg-utils" "desktop-file-utils" "alsa-lib")
+makedepends=("imagemagick" "npm")
+
+source=(
+ "https://github.com/oldj/SwitchHosts/releases/download/v${pkgver}/SwitchHosts-linux-x64_v${pkgver}.${pkgrel}.zip"
+ "https://raw.githubusercontent.com/oldj/SwitchHosts/master/assets/app.ico"
+ "${pkgname}.install"
+ "${pkgname}.desktop"
+)
+
+md5sums=('c051e239ce81a89d22b14c099c1afd66'
+ '88fe4a72cf9630119dd512c91b54edd9'
+ '0b6211b511da48346cecdc1d2f963c76'
+ '30df36e53ef2d815a2c2395f0378f9bb')
+
+package() {
+ install -dm755 "$pkgdir/"{opt,usr/bin}
+ mv "${srcdir}/SwitchHosts!-linux-x64" "${pkgdir}/opt/${pkgname}"
+ ln -s "/opt/${pkgname}/SwitchHosts!" "$pkgdir/usr/bin/switchhosts"
+ install -Dm644 ${srcdir}/${pkgname}.desktop "$pkgdir"/usr/share/applications/${pkgname}.desktop
+ mkdir -p "icons"
+ cd "icons"
+ convert ${srcdir}/app.ico logo_icon.png
+ cd -
+ sizes=(256x256 128x128 48x48 32x32 16x16)
+ for i in 0 1 2 3 4 5 ; do
+ install -d "${pkgdir}/usr/share/icons/hicolor/${sizes[$i]}/apps"
+ install -Dm644 "icons/logo_icon-${i}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${sizes[$i]}/apps/${pkgname}.png"
+ done
+}
diff --git a/switchhosts-bin.desktop b/switchhosts-bin.desktop
new file mode 100644
index 000000000000..4caaae553fa3
--- /dev/null
+++ b/switchhosts-bin.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=SwitchHosts
+Comment=Switch hosts quickly!
+Exec=switchhosts
+Icon=/usr/share/icons/hicolor/apps/switchhosts-bin.png
+Terminal=false
+Type=Application
+Categories=Development;
diff --git a/switchhosts-bin.install b/switchhosts-bin.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/switchhosts-bin.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}