summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 7 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c143ef1168b6..1057780b271a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sws
pkgdesc = A collection of features that seamlessly integrate into REAPER
- pkgver = 2.10.0
- pkgrel = 1
+ pkgver = 2.10.0.1
+ pkgrel = 2
url = http://www.sws-extension.org/
arch = x86_64
license = MIT
@@ -14,7 +14,7 @@ pkgbase = sws
provides = sws
conflicts = sws
source = git://github.com/reaper-oss/sws.git
- source = git://github.com/justinfrankel/wdl.git
+ source = git://github.com/justinfrankel/WDL.git/
source = https://swsaur.000webhostapp.com/files/reaper_plugin_functions.tar.xz
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 75fb9ceb51af..447fc2ccae94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: hfte@posteo.org
pkgname=sws
-pkgver=2.10.0
-pkgrel=1
+pkgver=2.10.0.1
+pkgrel=2
pkgdesc="A collection of features that seamlessly integrate into REAPER"
arch=('x86_64')
url="http://www.sws-extension.org/"
@@ -11,7 +11,7 @@ makedepends=('git' 'gcc' 'make' 'php' 'php-gd')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
source=("git://github.com/reaper-oss/sws.git"
- "git://github.com/justinfrankel/wdl.git"
+ "git://github.com/justinfrankel/WDL.git/"
"https://swsaur.000webhostapp.com/files/reaper_plugin_functions.tar.xz")
sha256sums=('SKIP'
'SKIP'
@@ -23,15 +23,8 @@ pkgver() {
}
prepare() {
- REAPERVERSION="$(pacman -Q reaper | cut -d' ' -f2 | cut -d'-' -f1)"
- if [-e reaper_plugin_functions/$REAPERVERSION/reaper_plugin_functions.h]
- then
- cp "reaper_plugin_functions/$REAPERVERSION/reaper_plugin_functions.h"\
+ cp "$srcdir/reaper_plugin_functions/reaper_plugin_functions.h"\
"$srcdir/$pkgname"
- else
- cp "reaper_plugin_functions/reaper_plugin_functions.h"\
- "$srcdir/$pkgname"
- fi
}