summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD31
2 files changed, 15 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4efbb390c2a..6488bc0a5f48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jul 5 02:03:58 UTC 2016
+# Tue Aug 2 18:18:02 UTC 2016
pkgbase = syncthing-discosrv
pkgdesc = Discover server for the syncthing P2P synchronization utility
- pkgver = 0.13.10
+ pkgver = 0.14.3
pkgrel = 1
epoch = 1
url = http://syncthing.net
@@ -18,11 +18,11 @@ pkgbase = syncthing-discosrv
makedepends = godep
makedepends = mercurial
depends = glibc
- source = https://github.com/syncthing/syncthing/archive/v0.13.10.tar.gz
+ source = https://github.com/syncthing/syncthing/archive/v0.14.3.tar.gz
source = syncthing-discosrv.service
source = syncthing-discosrv.tmpfiles.conf
- sha512sums = 199c38644a7e5d43777ca2e497d5304d8e77485d21aeed9a00efc74dd98bfb0c473dd0bf3230b8e1e9742315915419f198bb8d0a9b294d2f6fe918b6e0175812
- sha512sums = b2a8daa48be57ad47542569473128c8590d4bbe124de0912ce5b3de7deb1b54dd0d3ed66e925fc11addded075d24d6a1fe822d71338d128b7ca03fd43c082d8c
+ sha512sums = f9586013253ad031e1940e73f01f8ca398820e9ffeef0978fcd51079c535c04957c0be1314ecc635251ae06300c6b4141077ac5c3c8e7e9741d58e4545a7f3ba
+ sha512sums = 9d9d0b301cd88ecfad7b71f28ddf0ce62771af093a16504ef5a2bb227a101b4558d2fd5bd708f76ed11d9109e16cc61c420a5226865fdca9ced5955681bcd818
sha512sums = 28b0bb6a6f2fa536ec8cb887cfebf4706be25af5e29da39e2e3776daeeeb48f75fb5be255472920355948d8905830342866e89299facd626ddf8a658d84faf27
pkgname = syncthing-discosrv
diff --git a/PKGBUILD b/PKGBUILD
index 42ecca4cbaa5..5b8fbf06aa72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer : Kevin MacMartin <prurigro@gmail.com>
+_binname=stdiscosrv
_pkgname=syncthing
pkgname=$_pkgname-discosrv
epoch=1
-pkgver=0.13.10
+pkgver=0.14.3
pkgrel=1
pkgdesc='Discover server for the syncthing P2P synchronization utility'
url='http://syncthing.net'
@@ -19,43 +20,31 @@ source=(
"$pkgname.tmpfiles.conf"
)
sha512sums=(
- '199c38644a7e5d43777ca2e497d5304d8e77485d21aeed9a00efc74dd98bfb0c473dd0bf3230b8e1e9742315915419f198bb8d0a9b294d2f6fe918b6e0175812'
+ 'f9586013253ad031e1940e73f01f8ca398820e9ffeef0978fcd51079c535c04957c0be1314ecc635251ae06300c6b4141077ac5c3c8e7e9741d58e4545a7f3ba'
'b2a8daa48be57ad47542569473128c8590d4bbe124de0912ce5b3de7deb1b54dd0d3ed66e925fc11addded075d24d6a1fe822d71338d128b7ca03fd43c082d8c'
'28b0bb6a6f2fa536ec8cb887cfebf4706be25af5e29da39e2e3776daeeeb48f75fb5be255472920355948d8905830342866e89299facd626ddf8a658d84faf27'
)
build() {
- cd $_pkgname-$pkgver/cmd/discosrv
+ cd $_pkgname-$pkgver/cmd/$_binname
export GOPATH="$srcdir"
go get -d -tags purego
-
- case "$CARCH" in
- x86_64)
- export target='discosrv-linux-amd64'
- ;;
- i686)
- export target='discosrv-linux-386'
- ;;
- arm*)
- export target='discosrv-linux-arm'
- ;;
- esac
-
go build -i -v -ldflags -w
}
package() {
# Install systemd service and tmpfiles config
install -Dm644 $pkgname.service "$pkgdir/usr/lib/systemd/system/$pkgname.service"
- install -Dm644 $pkgname.tmpfiles.conf "$pkgdir"/usr/lib/tmpfiles.d/$pkgname.conf
+ install -Dm644 $pkgname.tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
# Install license and list of authors
cd $_pkgname-$pkgver
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 AUTHORS "$pkgdir/usr/share/licenses/$pkgname/AUTHORS"
- # Install documentation and binary
- cd cmd/discosrv
- install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
- install -Dm755 discosrv "$pkgdir/usr/bin/$pkgname"
+ # Install the man page
+ install -Dm644 man/$_binname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+
+ # Install the binary
+ install -Dm755 cmd/$_binname/$_binname "$pkgdir/usr/bin/$pkgname"
}