summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--syndicate-plus-gog.sh6
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c94b1ba12767..d538f00ea30f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syndicate-plus-gog
pkgdesc = In the dark and twisted cities of tomorrow, corporate syndicates compete for global dominance.
pkgver = 2.1.0.15
- pkgrel = 1
+ pkgrel = 2
url = https://www.gog.com/game/syndicate
install = syndicate-plus-gog.install
arch = any
@@ -24,7 +24,7 @@ pkgbase = syndicate-plus-gog
source = fix-permissions.sh
sha256sums = 671c5197f1a1dbe7fb3118a5f0c5595bb9d65693e1856f656eb4f572c99e1af0
sha256sums = 9972dfcceb58af7fa0ca258a1c8ecdffbd15fb817dc75f137afa9bc6bfae0256
- sha256sums = 78f956a693b56907632d701e777117f84abb4675fe4d4e8413e8618151f4e6e9
+ sha256sums = 8b5dd26aff37d7614e511a401e21cb51b017a8f2ce7d77974935aa5ae7cef8a6
sha256sums = 50b601b33522677a9bcaf23edc833329067bb87ccda33039c0b95f0d4ddca578
sha256sums = e90b33464517fb8b8102f3667755302e01fa10b7bec3d660357f802685416ca8
sha256sums = 693a4d7a323acc98ad2ff585b9f403b937367e9a7ed8f7b1993a98889422a5a8
diff --git a/PKGBUILD b/PKGBUILD
index fd32eaf68723..cf22111c4d26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=syndicate-plus-gog
pkgver=2.1.0.15
-pkgrel=1
+pkgrel=2
pkgdesc="In the dark and twisted cities of tomorrow, corporate syndicates compete for global dominance."
url="https://www.gog.com/game/syndicate"
license=('custom:eula')
@@ -27,7 +27,7 @@ source=("setup_syndicate_plus_$pkgver.exe"::"gogdownloader://syndicate/installer
sha256sums=('671c5197f1a1dbe7fb3118a5f0c5595bb9d65693e1856f656eb4f572c99e1af0'
'9972dfcceb58af7fa0ca258a1c8ecdffbd15fb817dc75f137afa9bc6bfae0256'
- '78f956a693b56907632d701e777117f84abb4675fe4d4e8413e8618151f4e6e9'
+ '8b5dd26aff37d7614e511a401e21cb51b017a8f2ce7d77974935aa5ae7cef8a6'
'50b601b33522677a9bcaf23edc833329067bb87ccda33039c0b95f0d4ddca578'
'e90b33464517fb8b8102f3667755302e01fa10b7bec3d660357f802685416ca8'
'693a4d7a323acc98ad2ff585b9f403b937367e9a7ed8f7b1993a98889422a5a8'
diff --git a/syndicate-plus-gog.sh b/syndicate-plus-gog.sh
index 36b36d620504..ce24bbe0e0fb 100644
--- a/syndicate-plus-gog.sh
+++ b/syndicate-plus-gog.sh
@@ -17,6 +17,7 @@ cat <<EOF
$script --windowed
$script --addon --client
$script --single --server
+ DOSBOX_CMD=dosbox-x $script
EOF
exit 0
}
@@ -26,6 +27,7 @@ popd() { builtin popd > /dev/null; }
INSTALL_DIR=/opt/syndicate-plus
HOME_DIR="$HOME"/.gog/syndicate-plus
+DOSBOX_CMD=${DOSBOX_CMD:-dosbox}
if which unionfs &> /dev/null; then
USE_UNIONFS=1
@@ -93,9 +95,9 @@ if [ "$USE_UNIONFS" ]; then
unionfs -o cow,relaxed_permissions "$UPPER_DIR=RW:$LOWER_DIR=RO" "$UNION_DIR"
echo "Launching game within $UNION_DIR"
- pushd "$UNION_DIR" && dosbox "${configs[@]}"
+ pushd "$UNION_DIR" && "$DOSBOX_CMD" "${configs[@]}"
popd && fusermount -u "$UNION_DIR"
else
echo "Launching game within $INSTALL_DIR"
- cd $INSTALL_DIR && dosbox "${configs[@]}"
+ cd $INSTALL_DIR && "$DOSBOX_CMD" "${configs[@]}"
fi