summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD31
-rw-r--r--cloud-station-drive.install12
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41f9edcef08a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 15:48:32 UTC 2016
+pkgbase = synology-cloud-station-drive
+ pkgdesc = Cloud Station Drive is an application which sync files between your computers and Synology NAS via the Internet, so that your data and documents are always up-to-date and stay beside you.
+ pkgver = 4203
+ pkgrel = 1
+ url = http://www.synology.com
+ install = cloud-station-drive.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = qt5-base
+ optdepends = nautilus: For nautilus integration
+ conflicts = cloudstation-beta
+ source_i686 = http://global.download.synology.com/download/Tools/CloudStationDrive/4.0-4203/Ubuntu/Installer/i686/synology-cloud-station-drive-4203.i686.deb
+ md5sums_i686 = f024335ded2e3fbada54013c2a948dfc
+ source_x86_64 = http://global.download.synology.com/download/Tools/CloudStationDrive/4.0-4203/Ubuntu/Installer/x86_64/synology-cloud-station-drive-4203.x86_64.deb
+ md5sums_x86_64 = cd5fadf8cb1500bacb51efca104a710a
+
+pkgname = synology-cloud-station-drive
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eeeab02e9c18
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!*.install
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cc9d7bc59a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Lev Lybin <aur@devtrue.net>
+
+pkgname=synology-cloud-station-drive
+pkgver=4203
+pkgrel=1
+pkgdesc="Cloud Station Drive is an application which sync files between your computers and Synology NAS via the Internet, so that your data and documents are always up-to-date and stay beside you."
+arch=('i686' 'x86_64')
+url="http://www.synology.com"
+license=('unknown')
+depends=('qt5-base')
+optdepends=('nautilus: For nautilus integration')
+conflicts=('cloudstation-beta')
+install=cloud-station-drive.install
+
+source_x86_64=(http://global.download.synology.com/download/Tools/CloudStationDrive/4.0-${pkgver}/Ubuntu/Installer/x86_64/synology-cloud-station-drive-${pkgver}.x86_64.deb)
+md5sums_i686=('f024335ded2e3fbada54013c2a948dfc')
+md5sums_x86_64=('cd5fadf8cb1500bacb51efca104a710a')
+source_i686=(http://global.download.synology.com/download/Tools/CloudStationDrive/4.0-${pkgver}/Ubuntu/Installer/i686/synology-cloud-station-drive-${pkgver}.i686.deb)
+
+prepare() {
+ cd "${srcdir}"
+ tar -zxf "${srcdir}/data.tar.gz"
+}
+
+package() {
+ cp -rp opt "${pkgdir}/opt"
+
+ install -Dm755 usr/lib/nautilus/extensions-3.0/libnautilus-cloud-extension.so "${pkgdir}/usr/lib/nautilus/extensions-3.0/libnautilus-cloud-extension.so"
+ install -Dm755 usr/bin/synology-cloud-station-drive "${pkgdir}/usr/bin/synology-cloud-station-drive"
+ install -Dm644 usr/share/applications/synology-cloud-station-drive.desktop "${pkgdir}/usr/share/applications/synology-cloud-station-drive.desktop"
+}
diff --git a/cloud-station-drive.install b/cloud-station-drive.install
new file mode 100644
index 000000000000..4d4a283dba5c
--- /dev/null
+++ b/cloud-station-drive.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}