summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66fb3cfb0219..cb82dd2272b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = sysexxer-ng-git
pkgdesc = A universal tool to exchange MIDI system-exclusive data
- pkgver = r11.e83f686
+ pkgver = r30.23dfc26
pkgrel = 1
url = https://github.com/linuxmao-org/sysexxer-ng
arch = i686
arch = x86_64
license = Boost
makedepends = git
+ makedepends = cmake
makedepends = gettext
depends = fltk
depends = jack
- depends = alsa-lib
+ depends = shared-mime-info
provides = sysexxer-ng
conflicts = sysexxer-ng
source = sysexxer-ng::git+https://github.com/linuxmao-org/sysexxer-ng.git
source = rtmidi::git+https://github.com/Wohlstand/rtmidi.git
source = simpleini::git+https://github.com/jpcima/simpleini.git
+ source = fmt::git+https://github.com/fmtlib/fmt.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3bb1ecfe24d7..a07e3082ff58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jean Pierre Cimalando <jp-dev@inbox.ru>
pkgname=sysexxer-ng-git
-pkgver=r11.e83f686
+pkgver=r30.23dfc26
pkgrel=1
pkgdesc="A universal tool to exchange MIDI system-exclusive data"
arch=('i686' 'x86_64')
url="https://github.com/linuxmao-org/sysexxer-ng"
license=('Boost')
groups=()
-depends=('fltk' 'jack' 'alsa-lib')
-makedepends=('git' 'gettext')
+depends=('fltk' 'jack' 'shared-mime-info')
+makedepends=('git' 'cmake' 'gettext')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
@@ -17,9 +17,11 @@ options=()
install=
source=('sysexxer-ng::git+https://github.com/linuxmao-org/sysexxer-ng.git'
'rtmidi::git+https://github.com/Wohlstand/rtmidi.git'
- 'simpleini::git+https://github.com/jpcima/simpleini.git')
+ 'simpleini::git+https://github.com/jpcima/simpleini.git'
+ 'fmt::git+https://github.com/fmtlib/fmt.git')
md5sums=('SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
noextract=()
@@ -35,6 +37,12 @@ prepare() {
git config "submodule.${submodule}.url" "${srcdir}/`basename "${submodule}"`"
done
git submodule update
+
+ cd thirdparty/fmidi
+ for submodule in thirdparty/fmt; do
+ git config "submodule.${submodule}.url" "${srcdir}/`basename "${submodule}"`"
+ done
+ git submodule update
}
build() {