summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--hidpi.patch9
-rw-r--r--system76-driver.install1
4 files changed, 9 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42cbeedd345b..8f0488f220b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-driver
pkgdesc = System76 Driver provides drivers, restore, and regression support for System76 computers
- pkgver = 17.10.25
+ pkgver = 17.10.32
pkgrel = 1
url = https://github.com/pop-os/system76-driver
install = system76-driver.install
@@ -14,22 +14,21 @@ pkgbase = system76-driver
depends = python-pynacl
depends = python-xlib
depends = dmidecode
+ optdepends = hidpi-daemon: Manage HiDPI and LoDPI monitors on X
optdepends = pm-utils: For power management features
optdepends = gtk3: To launch System76 driver and firmware GUI
optdepends = grub: To apply kernel boot time parameters
optdepends = polkit: Run System76 Driver GUI from application menu
optdepends = pulseaudio: To apply microphone fix
optdepends = xorg-xbacklight: To use the backlight service
- source = https://github.com/pop-os/system76-driver/archive/17.10.25.tar.gz
+ source = https://github.com/pop-os/system76-driver/archive/17.10.32.tar.gz
source = galu1.patch
source = gtk.patch
source = cli.patch
- source = hidpi.patch
- sha1sums = 80d987648e753ae3275f7de06dfeba98bc890761
+ sha1sums = d884fe547922182e312954a664b4aa99db46adda
sha1sums = ea8d53a80a26eb05b367f27996c8ce715aafba1e
sha1sums = bf0c37a6226858c768e8ce2c9c3c3801aef14c0e
sha1sums = 92f0de2acea6ac69c36378c7139fb84a7eaf7842
- sha1sums = acbcc10d4b4fc94bc33e9956fb0f4f335136beab
pkgname = system76-driver
diff --git a/PKGBUILD b/PKGBUILD
index 2fe29709c4ba..073b295a7493 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
pkgname=system76-driver
-pkgver=17.10.25
+pkgver=17.10.32
pkgrel=1
pkgdesc="System76 Driver provides drivers, restore, and regression support for System76 computers"
arch=('any')
@@ -21,6 +21,7 @@ depends=(
makepdepends=(
'python-pyflakes')
optdepends=(
+ 'hidpi-daemon: Manage HiDPI and LoDPI monitors on X'
'pm-utils: For power management features'
'gtk3: To launch System76 driver and firmware GUI'
'grub: To apply kernel boot time parameters'
@@ -31,13 +32,11 @@ source=(
"https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz"
'galu1.patch'
'gtk.patch'
- 'cli.patch'
- 'hidpi.patch')
-sha1sums=('80d987648e753ae3275f7de06dfeba98bc890761'
+ 'cli.patch')
+sha1sums=('d884fe547922182e312954a664b4aa99db46adda'
'ea8d53a80a26eb05b367f27996c8ce715aafba1e'
'bf0c37a6226858c768e8ce2c9c3c3801aef14c0e'
- '92f0de2acea6ac69c36378c7139fb84a7eaf7842'
- 'acbcc10d4b4fc94bc33e9956fb0f4f335136beab')
+ '92f0de2acea6ac69c36378c7139fb84a7eaf7842')
package() {
@@ -53,8 +52,6 @@ package() {
# Install daemons and executables
install -m755 -D system76-daemon ${pkgdir}/usr/lib/${pkgname}/system76-daemon
install -m755 -D system76-backlight-daemon ${pkgdir}/usr/lib/${pkgname}/system76-backlight-daemon
- install -m755 -D system76-hidpi-daemon ${pkgdir}/usr/lib/${pkgname}/system76-hidpi-daemon
- install -m755 -D system76-hidpi-notification ${pkgdir}/usr/lib/${pkgname}/system76-hidpi-notification
install -m755 -D system76-firmware-dialog ${pkgdir}/usr/lib/${pkgname}/system76-firmware-dialog
install -m755 -D system76-driver-pkexec ${pkgdir}/usr/bin/system76-driver-pkexec
install -m755 -D system76-firmware-pkexec ${pkgdir}/usr/bin/system76-firmware-pkexec
@@ -65,7 +62,6 @@ package() {
install -m644 -D debian/system76-driver.service ${pkgdir}/usr/lib/systemd/system/system76.service
install -m644 -D debian/system76-firmware.service ${pkgdir}/usr/lib/systemd/system/system76-firmware.service
install -m644 -D debian/system76-driver-backlight.service ${pkgdir}/usr/lib/systemd/user/system76-backlight.service
- install -m644 -D debian/system76-driver-hidpi.service ${pkgdir}/usr/lib/systemd/user/system76-hidpi.service
# Install scripts and configuration
install -m755 -D system76-nm-restart ${pkgdir}/usr/lib/${pkgname}/system76-nm-restart
@@ -74,7 +70,6 @@ package() {
# Install desktop shortcuts
install -m644 -D system76-driver-backlight.desktop ${pkgdir}/usr/share/applications/system76-backlight.desktop
- install -m644 -D system76-driver-hidpi.desktop ${pkgdir}/usr/share/applications/system76-hidpi.desktop
install -m644 -D system76-firmware.desktop ${pkgdir}/usr/share/applications/system76-firmware.desktop
# Install certificates and keys
@@ -101,7 +96,4 @@ package() {
# enabling "Restore System" button if all changes applied
patch --no-backup-if-mismatch -Np1 -i ${srcdir}/gtk.patch
-
- # Remove Ubuntu-specific service target
- patch --no-backup-if-mismatch -Np1 -i ${srcdir}/hidpi.patch
}
diff --git a/hidpi.patch b/hidpi.patch
deleted file mode 100644
index fcae5055b50e..000000000000
--- a/hidpi.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/usr/lib/systemd/user/system76-hidpi.service 2017-09-27 16:50:07.000000000 -0400
-+++ b/usr/lib/systemd/user/system76-hidpi.service 2017-11-09 23:57:02.406774919 -0500
-@@ -6,5 +6,5 @@
- Restart=on-failure
-
- [Install]
--WantedBy=ubuntu-session.target
-+WantedBy=default.target
-
diff --git a/system76-driver.install b/system76-driver.install
index 6045ba31cdc4..0fe24b862b86 100644
--- a/system76-driver.install
+++ b/system76-driver.install
@@ -34,7 +34,6 @@ cat << EOF
And the following user services:
system76-backlight.service Backlight Daemon for NVIDIA 9 Series on GNOME
- system76-hidpi.service System76 HiDPI Daemon
The backlight service can (optionally) be started automatically: