summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 196f73aca5e4..f384ded6c791 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-power-git
pkgdesc = System76 Power Management
pkgver = r160.1c347b8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pop-os/system76-power
install = system76-power-git.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index b5da3eb86a55..10a0573b5b22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=system76-power-git
pkgver=r160.1c347b8
-pkgrel=1
+pkgrel=2
pkgdesc="System76 Power Management"
arch=('any')
url="https://github.com/pop-os/system76-power"
@@ -26,14 +26,15 @@ pkgver() {
prepare() {
cd ${pkgname}
- patch -p1 -i ${srcdir}/graphics.patch
+ patch --no-backup-if-mismatch -Np1 -i ${srcdir}/graphics.patch
+
+ # Fix-up locations of daemon paths in service files
+ find . -type f -name '*.service' -exec sed -i -re "/^ExecStart/s/system76-driver/system76-power-git/g" "{}" \;
}
build() {
cd ${pkgname}
- #patch -p0 < ${srcdir}/graphics.patch
-
# Build and install base package
cargo build --release
}